Solved: Issues with MiFlora Sensor on OH 3

Have upgraded to 3 and getting the hang of it.
Having an issue with the MiFlora setup.

I have the daemon from thomas setup and running. Logging the data coming in from the miflora is running great.

[2021-10-12 03:05:43] Retrieving data from sensor "Sensor4" ...
[2021-10-12 03:05:43] Result: {"light": 14, "temperature": 22.7, "moisture": 0, "conductivity": 0, "battery": 100}
[2021-10-12 03:05:43] Publishing to MQTT topic "miflora/Sensor4"

I added a thing and it shows online.

I setup a channel…

UID: mqtt:topic:mqttbroker:sensor_4
label: Sensor 4
thingTypeUID: mqtt:topic
configuration: {}
bridgeUID: mqtt:broker:mqttbroker
  - id: sensor4_light
    channelTypeUID: mqtt:number
    label: Sensor 4 Light
    description: ""
      stateTopic: miflora/Sensor4/light

and added an item.

I get nothing coming back. Just null. Nothing occurs in the log when the sensor updates.

I am not sure how to configure the JSON. I tried a couple of options…


Neither seem to change anything.

Yes, I have the transform installed. I use for a sonoff POW to read the power data. No issue there.

Can’t figure out why my item wont update…


Try this:

stateTopic: miflora/Sensor4
transformationPattern: JSONPATH:$.light

Perfect! That got it! Thanks so much!