[SOLVED] Just installed openHAB, cant access it


i just installed openHAB on my windows server to toy around with it, but i can only access it using localhost:8080, not the ip address. Do i have to configure this somewhere? I tried to get a hint in the tutorials, but appearently it should just work …

On a sidenote: do i need the java runtime or a JDK? I am using the latest oracle runtime and get an error for KARAF_HOME, which can be solved installing a JDK (according to the error).

Thanks so much.

Sounds like you need to open the port in your Windows firewall.

I don’t run on Windows but if the error says to install the jdk that is the first thing I would try.

Did you configure Java as described in the docs

Use ‘netsh’ to control that something is listening on Port 8080

Well i can access it via localhost:8080, so it is somewhat working. The network interface does not work though. The firewall is disabled.

The important thing is that i dont need to manually configure a network interface as listener, right? So the error must be somewhere else, maybe some leftover routings or something on the server.


That is correct. The problem probably lies somewhere outside of OH.

How did you resolve this?
I’ve just updated Java to get round the handshake error to the marketplace and now I can only access via localhost. The ipaddress:8080 doesn’t work via the LAN.
Strangely, I can access via myopenHAB.org so there appears to be a way in. I presume it’s a Windows/Java problem but don’t know where to start looking.

I have the exact same problem, after a Java update I could not access openhab via the LAN (but it woks ok on the localhost). Have you figure out how to fix that?

Yes I did but can’t remember how annoyingly.
I know it wasn’t overly difficult. Check the Windows environment variables like path are correct. Shut down openHAB in services.msc and reboot and see if it solves it.

Thanks for your reply. I just fixed the problem by updating the java setup in the localhost windows firewall:

Control Panel > Windows Defender Firewall > Advanced settings > Inbound Rules > Java… > programs and Services > update the file reference to point the new java.exe location


I have the same issue. How did you solved it?