[SOLVED] Knx Binding - Bridge Online - Device Offline

Hi all,
I’m writing from Portugal, and it is my first issue. I have a KNX home installation and decided to begin in OpenHab world. And I’m trying to do the “Hello World”.

Have installed the OH in a Windows10 virtual machine for testing purpose. In the future will do in a RPi.
Starting about the issue, have created the KNX interface, with no issues, as you can see the status is Online.
But when I was trying to setup an item/thing/channel it appears to me always as Offline.
Please find the details about this:

  • Bridge online.
  • KNX Device Physical Address: 0.0.28
  • KNX Group Address: 2.3.0
  • have added also the ETS addresses for your confirming.

Any toughts,?
And apologies about my noob doubt.

Regards

  1. In your device it says bridge offline.
  2. The group address should be 2/3/0.

Thanks for Reply

  1. Sorry. I printed in the middle of some test. It shows status online.
  2. Do you mean 2/3/0 instead of 2.3.0 in the channel?

What are the parameters of your device? What does the log say?

P.S.: Are you sure your gateway is online?

As a first test, please leave address for the Thing empty as well as localSourceAddr for the Bridge.

The Group Addresses are written with slashes instead of dots, so your GA should be read as 2/3/0, not 2.3.0 (This part is the channel config)

Thanks.
If I remove the Thing/Device address and remove the localSourceAddr in the Bridge I have this result:
image

The gateway is working. And if i change it to other IP it comes offline. So I’m assuming it is online for Openhab.

Parameters:

Log:
14:34:54.766 [INFO ] [marthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
14:34:55.782 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED)
14:34:55.797 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:06356207’ changed from UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED)
14:34:55.797 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:ip:215e45a7’ changed from UNINITIALIZED to INITIALIZING
14:34:55.813 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:ip:215e45a7’ changed from INITIALIZING to UNKNOWN
14:34:55.954 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from UNINITIALIZED (BRIDGE_UNINITIALIZED) to INITIALIZING
14:34:55.969 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE)
14:34:55.969 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:06356207’ changed from UNINITIALIZED (BRIDGE_UNINITIALIZED) to INITIALIZING
14:34:55.969 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:06356207’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE)
14:34:56.016 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:ip:215e45a7’ changed from UNKNOWN to ONLINE
14:34:56.016 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from OFFLINE (BRIDGE_OFFLINE) to UNKNOWN
14:34:56.016 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:06356207’ changed from OFFLINE (BRIDGE_OFFLINE) to UNKNOWN
14:35:09.094 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:06356207’ changed from UNKNOWN to OFFLINE
14:35:21.141 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from UNKNOWN to OFFLINE
15:07:49.964 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:ip:215e45a7’ changed from ONLINE to OFFLINE
15:07:49.964 [INFO ] [smarthome.event.ThingUpdatedEvent ] - Thing ‘knx:ip:215e45a7’ has been updated.
15:07:49.964 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:ip:215e45a7’ changed from OFFLINE to UNKNOWN
15:07:49.964 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from OFFLINE to OFFLINE (BRIDGE_OFFLINE)
15:07:49.979 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:06356207’ changed from OFFLINE to OFFLINE (BRIDGE_OFFLINE)
15:07:49.979 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:ip:215e45a7’ changed from UNKNOWN to ONLINE
15:07:50.073 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from OFFLINE (BRIDGE_OFFLINE) to UNKNOWN
15:07:50.073 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:06356207’ changed from OFFLINE (BRIDGE_OFFLINE) to UNKNOWN
15:08:03.239 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:06356207’ changed from UNKNOWN to OFFLINE
15:08:16.986 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from UNKNOWN to OFFLINE
15:08:55.771 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from OFFLINE to UNKNOWN
15:08:55.856 [INFO ] [smarthome.event.ThingUpdatedEvent ] - Thing ‘knx:device:379cea38’ has been updated.
15:09:09.227 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from UNKNOWN to OFFLINE
15:09:54.005 [INFO ] [smarthome.event.ThingUpdatedEvent ] - Thing ‘knx:device:379cea38’ has been updated.
15:09:54.051 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘knx:device:379cea38’ changed from OFFLINE to ONLINE

have sent the log after changed the address for the thing and for localSourceAddr as empty, per suggestion of other user.
thanks

Your device is online, can you turn on/off the light?

Hi,

The device is online after left it as empty. Doesn’t have address in the device.

Sorry about the misunderstanding. Remove the address due to a suggestion in a above suggestion.

Hi folks

Fixed the issue.

I have changed the Local Device Address, in the bridge, from 0.0.50 to 0.0.0 and it solved.

Many thanks for your support.

1 Like