[SOLVED] KNX Binding: no confirmation reply received

Hi @PeteW,

Check please your /etc/openhab2/services/knx.cfg file

For Router mode, it should have the following settings:

ip= # the Multicast IP
busaddr=0.0.1 # the PA of the dummy App for OpenHAB2
type=ROUTER # connection type for multicast
localIp=192.168.1.??? # your OpenHAB2 Host IP Address



2016-10-26 20:51:52.578 [INFO ] [nx.internal.connection.KNXConnection] - Established connection to KNX bus on in mode ROUTER.

It was the busaddr=0.0.1 i was missing!!!

Now will try and access the group addresses!

Many, many thanks!

Will see where i get to next!


:slight_smile: Hold your horses :slight_smile:

This is good progress…but… that message (established connection) is a bit misleading… because at that moment in time, OpenHab 2 just believes that everything is ok (after reading the config files and loading up the KNX Binding).

Unfortunately, at that moment in the log, there is no verification / confirmation received by OpenHab from the GIRA KNX/IP Router that a connection has been established.

The only real test is done after you configure your items and sitemap and try to play around with them… if this works… you are all set and the binding is working fine.

I wish you luck for the next step :slight_smile: Let me know how it goes!


ok, I’ll tread carefully!! Let me see if I can get to the next stage. Will let you know how i get on ! Thanks again.


1 Like

Oh…and I had my IP Router IP address set as ‘KNX gateway IP address’ before ( instead of the multicast address of

Bit misleading in the config file as it says "KNX gateway IP address’… I’d never have got that without your help!

Think it should say ‘multicast address’ to help!


When using Router connection type, this ip setting is optional since it defaults to the correct Multicast IP (
If this setting is used, it should be configured to the Multicast IP Address allocated to KNXnet/IP.

I usually set it to avoid problems (see: KNX Binding Configuration Changes cause Exception). It’s just a pre-caution :slight_smile:

Is the ‘localIP’ address optional too if in ROUTER mode? I say that as I’m working on my MAC with DHCP, so i need to check I’ve not got a new IP address if i reconnect to the network!

Yup, ‘localIP’ is also optional. OpenHab will automatically detect it from your local hosts file (it’s ok to use DHCP for your OpenHab host but it’s not really recommended :slight_smile: ).

It helps if you are running OpenHab on a host with multiple IP Interfaces/Addresses and you need to instruct OpenHab to use a specific IP for multicast communications to the KNX Router (to be on the same IP subnet).

Hi Dim

Can you give me a couple of examples of your KNX bindings in HAB 2. Can’t find much doc on how/where to setup the channel. Its changed from HAB 1.8, so need to re-do my items


Sure. Example config:


Switch	My_Light	"My Light"	{knx="1/0/1+<1/2/1"}

The knx binding info is: On/Off GA (1/0/1), then + sign for Status GA (1/2/1) and < sign for status read request on OpenHab startup.


Switch item=My_Light

Start small, test 1 KNX item using your Group Addresses and then start to enhance the configs. Also: Try to avoid using complex stuff at this troubleshooting stage (e.g. no rules, etc).

Since the KNX Binding in OpenHab 2 is still version 1.x, it uses the same formatting as the one used in OpenHab 1.
The locations of the files are different, but the syntax of their contents should remain the same

1 Like

ah, ok. So it’s pretty similar to 1.8 for the KNX bindings. Don’t need to worry about the channel setting stuff.

Will give this a try

Yeah… Forget things and channels for now or using Paper UI to configure your KNX stuff
You use Paper UI only to install the KNX Binding at the very beginning (you already did that)

Everything around configuration of KNX items is still being done with config files (just like OH1)
When KNX Binding version 2.x will arrive… many things will change (for the better :))

just tried 1 light. but when I used openHAB to turn it on it was flickering on and off! Will take a look when have more time, but at least I’m now communicating - which is fantastic progress

Thanks a lot!!


that problem (flickering on/off) is immediately solvable with:


in you /etc/openhab2/services/knx.cfg

Restart OpenHab 2 afterwards.

sorry… forgot to mention that :slight_smile:

You are all set, up and working ! :sunglasses: :sunglasses: :sunglasses: (you are welcome)

1 Like

YEP - that was it!!!

Fantastic stuff :smiley: :grinning::smile:

Will let you know how i get on with others swtches/controllers…have heating and lighting all on KNX…

Harmony remote and Onkyo amp were picked up by openHAB as ‘things’ automatically too!

…think i have a busy weekend ahead!


1 Like

Hi Dim

Just as an update…have made great progress…

Got a lot of my lights switching on and off now, its very responsive - just as good as the Gira Homeserver.

I was running on my Mac, but have now ‘splashed out’ on a Raspberry Pi and got that all up and running too. What a great bit of kit that is! I’ve sat it on top of my Homeserver!

Now I’m out in the ‘IP World’ I’ve been testing out an Amazon Echo. And, hey, I’ve even got that working too. Using a HA Bridge which fools the Echo into thinking that my KNX light switches are Philips Hue - its great!

Will keep you updated on progress. Next step, temp monitoring!


Great news ! :slight_smile:
Have fun with the configs!

You mean… better ? :wink: :sunglasses:

Of course it’s better :smiley: - but I can’t admit that as HomeServer cost me a fortune!!! :sob:

Have you tried the recently updated KNX 1.9.0-SNAPSHOT binding? @lewie recently updated it and it would be good to see if it still works as intended for your installations (not that I doubt it, but it might work even better than previous).

yes, am on that. seems to be working well - thanks