[SOLVED] KNX Binding: no confirmation reply received

Thanks Dim

I’ll try this out tonight. Sounds logical to me. Will update the PA. Assume the HomeServer will still work ok in the new mode?


Hi @PeteW,

HomeServer should continue to work even after the PA change. Check the HomeServer configuration in advance to see how it is set to connect to the GIRA Router. It should be based on tunnel config (with the IP of the Router).
If anything goes wrong, revert back to the original PA (1.0.255).

Since the IP will not change, the HomeServer will be able to connect to the Router without problems and establish a tunnel.

Remember to configure the Filter Table also on the KNX Router. Add a dummy application in your ETS Project that represents OpenHab and link the Group Addresses that you want to allow to be routed between the 2 “worlds” (KNX Bus and IP). Put this dummy App in a new Line (e.g. 1.1) and give it a PA in that new line (e.g. 1.1.200). Then, link the GAs to the dummy app and the ETS will automatically calculate the Filter Table for the Router. Reprogram the Router afterwards using ETS.


Think I’ve stumbled on another issue…

When I try to change the PA in ETS4 of the IP Router is says 'Set Address of Device ‘0.0.255 FC01 router’ to ‘0’ failed. The usage of IP routers requires a IP backbone line.

Do I need to create a new line with just the IP router on it now? Currently it is on the same line as all the other KNX devices.


Hi @PeteW,

The Router should remain in the existing position in the ETS Project (within the existing Line).

The error that you are getting is because your Backbone Area has “TP” set as the Backbone Medium (this is the default in ETS Projects).

To change that to IP, go to the Topology Workplace Panel in ETS and select Topology from the left side, then Properties->Settings->Backbone Medium->IP.

Here is my setup (with the extra line holding the dummy application for configuring the filter table in the router):

Ah…that moved all my devices from Line1. When I try to drag them back I get an error

Am on ETS4 not ETS5, but that shouldn’t make a difference I don’t think

? Changing the Backbone Media moved your devices from Line 1 ? That’s strange…

Keep Line Medium to TP. In this way, you shouldn’t affect your existing devices. All the old devices (and the Router) should stay where they are (in the existing Line)
Change Backbone Media to IP to allow you to reconfigure the PA of the Router

Also: Use the Undo function if something goes obviously wrong. Don’t try to move more stuff around since this could create a mess :slight_smile:


Will give that a try tonight.

Think I understand what I’m trying to do…

  • My KNX modules all talk over TP
  • openHab needs to talk IP
  • my KNX IP router is the link between
  • KNX IP router needs to see all telegrams
  • having an IP backbone links the TP and IP worlds together

Am I getting that right? (I’m not really a networks guy!)


Correct :slight_smile:

The Link between the 2 “worlds” (TP and IP) is the Router.
It is positioned in the TP Line since it is primarily a TP device and can see all KNX Telegrams from other TP devices in its line.
The Backbone should be set to IP to allow the Router to communicate the Telegrams “upwards” towards the IP “world”

For further reading, see attached :slight_smile: 08_IP Communication_E0510a.pdf (320.1 KB)

Great - thanks

So the HomeServer must talk TP, which is why that works ok in my setup and openHab doesn’t (yet!)

Be great to get this working as it will really open up options for me


Well… I don’t have a GIRA HomeServer, but from what I know, it is a regular IP host/device (similar to a Raspberry Pi or a PC running OpenHab)

It has it’s own IP Address and connects over IP to the GIRA KNX/IP Router.
The HomeServer does not directly “talk” TP since it doesn’t have an interface for KNX Bus.

In theory, the HomeServer establishes a Tunnel connection over IP to the Router and can receive/transmit Telegrams from/to the KNX Bus via the Router.

In parallel, we will configure the GIRA KNX/IP 103000 Router to properly use Multicasting so that OpenHab 2 can also communicate with the Router (using the 2nd method: routing) so that we can also access KNX Telegrams over IP.


ok…have managed to add an IP backbone AND change the router address…so getting there…

Here’s my new topology

You’ll see I’ve linked the group addresses I want to use to the dummy oenHAB app.

I have also updated the group address and application software in the router using ETS.

Ran openHAB again in ROUTER mode, still seem to be getting the ‘waiting for connection’ message ;-(

Does my setup look right now Dim?


btw…the HomeServer still works ok with the new PA set for the router - so that’s good

Hi @PeteW,

Topology looks good, Router is placed properly in TP Line, dummy App is configured correctly ! (and HomeServer is good :slight_smile:)

…it should have worked by now :frowning:

Ok… now we need to check the OpenHab logs… Please enable trace for the KNX communications by:

(assuming that you are running OpenHab 2… by the way… which OH version are you running?):

  1. Enter in Karaf Console with “sudo ssh openhab@localhost -p 8101” (password habopen)
  2. Suppress all other log types: “log:set ERROR” & “log:set ERROR org.openhab
  3. Enable max logging for KNX comms: “log:set TRACE org.openhab.binding.knx” & “log:set TRACE tuwien.auto.calimero
  4. Restart OH2: “sudo systemctl restart openhab2
  5. Test some actions from your sitemap
  6. Upload a copy of /var/log/openhab2/openhab.log

Let’s see what the logs say and we take it from there :slight_smile:


I’m actually running openHab 1.8.3 with KNX binding v1.8.3. Thought i’d get it working on the stable release first. Do you think i should move to 2.0?

2.0 is the future :slight_smile:

Also, the KNX Binding is being prepared by the developers for many great things in 2.0.

I do recommend going to 2.0 Beta 4. It is very stable and I have it running for 4 months now without (major) hiccups.

Download 2.0 Beta 4 from here: https://bintray.com/openhab/mvn/openhab-distro (or even better, follow the apt-get instructions in the wiki below if you are deploying in a Linux host)
Installation wiki here: http://docs.openhab.org/installation/index.html


Have downloaded and will connect it up to my KNX tonight. UI looks great and the config appears much easier.

1 Like

Got 2.0 up and running!

Realised i had the wrong gateway address in the KNX IP router (was to my old b/band router that’s now changed. Should be not

Have tried to connect, and getting the following new error…

2016-10-26 20:24:52.555 [ERROR] [nx.internal.connection.KNXConnection] - Error connecting to KNX bus: wrong KNX address syntax with 4 levels
2016-10-26 20:24:52.555 [WARN ] [nx.internal.connection.KNXConnection] - Initial connection to KNX bus failed!

What do you recon?

Hi @PeteW,

Check please your /etc/openhab2/services/knx.cfg file

For Router mode, it should have the following settings:

ip= # the Multicast IP
busaddr=0.0.1 # the PA of the dummy App for OpenHAB2
type=ROUTER # connection type for multicast
localIp=192.168.1.??? # your OpenHAB2 Host IP Address



2016-10-26 20:51:52.578 [INFO ] [nx.internal.connection.KNXConnection] - Established connection to KNX bus on in mode ROUTER.

It was the busaddr=0.0.1 i was missing!!!

Now will try and access the group addresses!

Many, many thanks!

Will see where i get to next!


:slight_smile: Hold your horses :slight_smile:

This is good progress…but… that message (established connection) is a bit misleading… because at that moment in time, OpenHab 2 just believes that everything is ok (after reading the config files and loading up the KNX Binding).

Unfortunately, at that moment in the log, there is no verification / confirmation received by OpenHab from the GIRA KNX/IP Router that a connection has been established.

The only real test is done after you configure your items and sitemap and try to play around with them… if this works… you are all set and the binding is working fine.

I wish you luck for the next step :slight_smile: Let me know how it goes!