[SOLVED] KNX Binding w/ knxd on same machine give only timeouts - knxtool working!

I have installed openhab2 on a Raspi3 using latest openhabian. I don’t get the knx binding running.

My configuration:

  • Raspi 3 with openhabian, local IP-Addr

  • knxd 0.12 / 0.14 (see below) running on the same machine

  • TUL (busware.de) which is running with the same knxd and FHEM on another Debian machine smoothly

  • my /etc/openhab2/services/knx.cfg:


  • my knxd command line:

knxd -t 0xffc -f 9 --client-addrs=9.9.1:8 --eibaddr=1.1.251 -d -D -T -R -S -i --listen-local=/tmp/knx tpuarts:/dev/ttyACM0

My expectations:

  • After restart of openhab2 I want to be able to see my edited eib.items bound to knx so that I am able to use them in OH2

What happens

  • After restart of openhab2 I see error messages in /var/log/openhab2/openhab.log like this:

    2017-05-17 10:32:56.293 [ERROR] [tuwien.auto.calimero ] - KNXnet/IP Tunneling establishing connection failed, timeout connecting to control endpoint /
    2017-05-17 10:32:56.293 [ERROR] [nx.internal.connection.KNXConnection] - Error connecting to KNX bus: timeout connecting to control endpoint /
    2017-05-17 10:32:56.296 [WARN ] [nx.internal.connection.KNXConnection] - Initial connection to KNX bus failed!

What I did to find the error

  • netstat -lpt confirms that knxd is listening on
  • Upgrading the installed knxd 0.12 to latest knxd 0.14 - this didnt help
  • running knxtool vbusmonitor3 ip:localhost -> this is working !
  • trying the TUL in another machine together with knxd 0.12 and tried to change the ip - setting in knx.cfg to the local ip address of this other machine -> didnt change a piece
  • Used knxd in debugging mode with -f 9 … -> during start of openhab2 the knxd shows no output in debug log.

Any ideas?

I don’t use knxd so I don’t know if your command line parameters are ok… (seems so… maybe a -b is missing before tpuarts:/dev/ttyACM0 ?)
I would try to use router type to see if this will help and then try to troubleshoot the tunnel type.


Finally I got this working when running knxd on another machine (@

I changed my knx.cfg to:

ip= # Address of KNXD-running maschine
localIP= # Address of openHabian

What I had not understand earlier is that OH seems only to work with the UDP-Port 3671 and not with the TCP-Port 6720 (which is working in the same setup with other applications).