[SOLVED] KNX Configuration has gone bad :-)

Hi folks,

I´m running openhabian in version (2.3.0-1) and did´t update it for about 8 weeks (bad, I know :slight_smile: )
Today I did that and somehow it broke my knx configuration (Paper UI says it´s binding version 2.3.0)

I installed the knx binding newly and checked, if the knx.cfg is still up to date …

Everything is, it seems, as before, but openhab is never mentioning knx setup in openhab.log during start up, neither does It work afterwards (but then, how should it… )

Is there some new concept I didn´t get in the last 2 month, or am I just too …??

I checked my KNX Router with ETS and it works like a charm, so it IS openhab which makes problems :frowning:

Any hints how i could start investigating ?

Thanks and greetings,

Wurzelseppi

Binding KNXv2 has been released
I requires a different way of configuration (doesn’t use knx.cfg)
Read about it here: https://www.openhab.org/addons/bindings/knx/

If you would like, you can stay on KNXv1 and continue using knx.cfg

1 Like

Wow, that was fast … thanks dude …
Yeah, have to go back …

How can I do this ?

I need time to have a look into new version …

Many thanks again!

  1. uninstall the KNXv2 binding from PaperUI
  2. Enable Legacy 1.x Bindings in PaperUI->Configuration->System
  3. Install KNXv1 binding from PaperUI

Oh wow … just changed my status in my house from useless to god again …

Wonderful … thanks again … go grab a beer!! … you absolutely earned it :slight_smile:

Cheers,

Wurzelseppi

1 Like