[SOLVED] Knx temperature reading does not work

Hi Everybody,

i just tried to integrate my knx temperature GA from my thermostat in openhab 1.
Here is my item:
Number temp_hall "Temperature [%.1f °C]" <temperature> { knx="<2/0/0" }
My sitemap :
Text item=temp_hall label="Temperature"

On my app, no value is printed at all. However, on my KNX bus monitor i can see : “20,1” (this is my temperature), maybe the problem is related to french comma separator ?

Thanks very much for any help

Try to use

Number temp_hall "Temperature [%.1f °C]" <temperature> { knx="<9.001:2/0/0" }

(where 9.001 is the DTP)

Hi Udo,

thanks for helping. I tried with this line but it does not work better. But i’m not sure about the datatype, i tried the one you specified (which looks the right one).

Here is the debug line
22:49:41.427 [DEBUG] [.KNXBindingDatapointReaderTask:58 ] - Autorefresh: Waiting for new item in reader queue
22:49:41.428 [DEBUG] [.KNXBindingDatapointReaderTask:60 ] - Autorefresh: got new item temp_hall in reader queue
22:49:41.429 [DEBUG] [.KNXBindingDatapointReaderTask:64 ] - Autorefresh: Trying to read form KNX bus: command DP 2/0/0 temp_hall, DPT main 0 id 9.001, low priority
22:49:41.430 [DEBUG] [.KNXBindingDatapointReaderTask:92 ] - Autorefresh: Sending read request to KNX for item ‘temp_hall’ DPT '9.001’
22:49:41.489 [DEBUG] [.b.knx.internal.bus.KNXBinding:169 ] - Received groupWrite Event.
22:49:41.490 [DEBUG] [.KNXBindingDatapointReaderTask:70 ] - Autorefresh: DatapointReaderTask Waiting 50 msecs to prevent KNX bus overload

Thanks again

Hi again,

is there something i can add to help the debug ?

Thanks by advance !

Hi again,

sorry to insist but is it possible to retrieve directly knx value from a cli command in order to be able
to debug that ?


HI everybody,

Up please :slight_smile:


Hi Djazz,
sorry for bringing up this topic again but I have the same problem.
Here is my item:

Number EG_Bad_Temperature “Temperatur [%.1f °C]” (EG_Bad, gTemperature) {knx="<9.001:11/1/0"}

and in the sitemap:
Default item=EG_Bad_Temperature label=“Badezimmer [%.1f °C]”

Although the temperatur-controler sends the corresponding GA every minute on the bus I get no values in my app.

Is your problem solved and if it is how did you get the values?
Is the “Default” the problem? It works fine for Lights and Rollershutter.

Greetings and thanks in advance.

Hi Dram,

Here is my working configuration :

/* Indoor Temperatures */
Number temp_hall_cible "Temperature [%.1f °C]" <temperature> { knx="2/0/2+<9.001:2/0/3" }
Number temp_hall "Temperature [%.1f C]" <temperature> { knx="+<9.001:2/0/0" }

for site map :

        Frame label="Chauffage" {
                Setpoint item=temp_hall_cible label="Temperature cible [%.1f C]" minValue=16 maxValue=24 step=0.5
                Text item=temp_hall
                Switch item=pompe_chauffage label="Chauffage" icon="light"

Hope it will help

Are there events logged about the GA 11/1/0?