[SOLVED] KNX2 can`t use 5.005 DPT with AC unit

The task is to control AC unit which connected to KNX from KlicDD gateway
I have such thing:

Thing device AirUnitLiving "AirUnit Livingroom"
        Type    switch:      AirUnitLivingPower      [ga="1/6/1+<1/6/2"]
        Type    number:      AirUnitLivingMode       [ga="5.005:1/6/5+5.005:<1/6/6"]
        Type    number:      AirUnitLivingTempSet    [ga="9.001:1/6/3+9.001:<1/6/4"]
        Type    switch:      AirUnitLivingSwing      [ga="1/6/10+<1/6/11"]

Such part of items

Switch AirUnitLivingPower   {channel="knx:device:bridge:AirUnitLiving:AirUnitLivingPower"}
Number AirUnitLivingMode1 "AirUnitLivingMode"  {channel="knx:device:bridge:AirUnitLiving:AirUnitLivingMode"}
Number AirUnitLivingTempSet   {channel="knx:device:bridge:AirUnitLiving:AirUnitLivingTempSet"}

Such part of sitemap:

			Group item=AirUnitLiving
				Frame label="Controls"
   					Switch 		item=AirUnitLivingPower 	label="Power" icon=switch
   					Switch 		item=AirUnitLivingMode 		label="Mode" mappings=[0="Auto", 1="Heat", 3="Cool", 9="Fan", 14="Dry"]
   					Setpoint 	item=AirUnitLivingTempSet 	label="Set temperature" icon=temperature minValue=16 maxValue=30 step=1

AirUnitLivingPower and AirUnitLivingTempSet are woking good. I can on\off AC unit, change temperature from any control unit: OH, KNX panels, AC remote control.

But AirUnitLivingMode doesnt work. Yes, I can change it in OH visualization and I see the changes in logs. But I dont see any telegrams in KNX, and no reaction with AC unit. In other way, if I changes mode AC unit from KNX, I don`t see any reaction on OH too.
I tried to change DTP to 5.001, but I have the same thing.

What I need to do?

Type    number:      AirUnitLivingMode       [ga="5.005:1/6/5+5.005:<1/6/6"]
Type    number:      AirUnitLivingTempSet    [ga="9.001:1/6/3+9.001:<1/6/4"]

this is wrong (was correct in knx1 definitions…)
Please try

Type    number:      AirUnitLivingMode       [ga="5.005:1/6/5+<1/6/6"]
Type    number:      AirUnitLivingTempSet    [ga="9.001:1/6/3+<1/6/4"]



It seems to work! BIG Thanks!!!

1 Like

Now in logs I see

[ERROR] [ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item for widget org.eclipse.smarthome.model.sitemap.Group

The system seems to working, but what does error mean?

I found my mistake. All woks ok.


Hi Pavel, I get the same error - how did you solve this issue?
BR, Thomas

Try to denote all Groups of *.sitemap in *.items.

Thanks Pavel - Did work out! :slight_smile:

Будь ласка)) You are welcome!

i have the same problem with dtp 5.005. Will give it a try.