[SOLVED] KNX2 UoM and SetPoint - What am I missing (migrating from knx1)?

after my raspberry pi crashed and burned, I had to recover and reconfigure everything which got destroyed. After recovery i also started with the migration from onewire1 and knx1 to the version2 variants. I must first admit, that I switched yesterday to snapshot for one OneWire2 feature and stayed there after everything worked with my knx1 configuration.

It took me quiet a while to accept the abstraction from items to items and things. Now I like this documentations feeling of it and optimizing small things on ETS as well. I had no problems with Switches, Contacts, Sensors (Lux, kWh, Wh, Windows, Percentage, …). But now I was sitting for a couple of hours on my Heating SetPoints for my Rooms. Nothing worked.

I just figured out, that UoM seems to be the problem. The Workflow seems to be:

  • Thing: Data received as a float
  • Item: Data converted to UoM Value
  • User: Uses SetPoint to increase the Value on the Item
  • Item: Sends Data to the Thing
  • Thing: Evaluates the UoM and realises the KNX GA can’t work with the String “20 °C”
  • [User: Can’t figure out the Problem without enabling the Debug logs]

Error Message I got:

None of the configured GAs on channel ‘knx:device:bridge:heizung-eg:kanal-d-sollwert-komfort’ could handle the command ‘19 °C’ of type ‘QuantityType’)


Number Temperature_EG_Guest_Setpoint “Gästezimmer [%.1f °C]” <temperature> (gGuestthermostat,Temperature_Setpoint) [ “TargetTemperature” ] {channel=“knx:device:bridge:heizung-eg:kanal-d-sollwert-komfort”}


Type number : kanal-d-sollwert-komfort “Sollwert Komfort - Gästezimmer” [ ga = “9.001:5/2/42+<5/2/44”]

Everything works as I expect as soon as I remove “°C” from the items configurations (which are there since OpenHAB1.x)

So my Questions is basicly the following:

  • What am I missing in the UoM abstraction? or is it just a Snapshot Problem?
  • Is there a workaround (except writing a rule for 16 Things/Items)?
  • If its not a Snapshot Problem - will there be a conversion in 2.5 (especially since there are default DPTs or custom defined DPTs)?


No, knx does not provide UoM channels and can’t handle UoM at all.

But your item is no UoM Item either (you would have to write Number:Temperature instead of Number)

Where does the setpoint temperature come from?
If using similar function with different items, if chosing the item names wisely, it’s easy to build one rule which can handle all of them.

Hi Udo,
thanks for your reply.

I set the SetPoint over the Webinterface (sitemap definition) without any conversions or scripts.


Setpoint item=Temperature_EG_Guest_Setpoint minValue=16 maxValue=28 step=0.5

It only seems to be a UoM Item as soon as I have in the item description an “[%.1f °C]”. I even tried to move °C behind the brackets (this actually caused it to be UoM and not be displayed)

I just checked everything twice and then I cleared the openhab cache - the behaviour is now gone. (I hate and love when this happens).