[SOLVED] Knxd versions newer than 0.14.19-2 do not start at boot

The knx daemon, installed with the openhabian-config script, starts automatically at boot using systemd. It uses the script: /lib/systemd/system/knxd.service with the parameters written in /etc/default/knxd.
The default parameters suggested at installation (KNXD_OPTIONS="–eibaddr=1.1.128 --client-addrs=1.1.129:8 -d -D -T -R -S -i --listen-local=/tmp/knx -b tpuarts:/dev/ttyAMA0") was good until version 0.14.19-2.
As explained on knxd github the “-d” parameter is needed to demonize the program when launched manually from cli, so it’s redundant when launched by systemctl, but was “tollerated” until that version.
Using that parameter starting from version 0.14.22 causes the program to quit immediately with exit code [0]Success, even if it still good using the cli.
It must be removed manually editing /etc/default/knxd.
The correction must be repeated if you reinstall knxd (now at version 0.14.23) because openhabian-config installation repropose the same configuration file.

Did you already open an issue at github?

Not yet. I solved the issue with a bunch of friends very recently.
Your suggestion is good, I’m going to do that.