[SOLVED] Kostal Pleticore 7 plus solar Inverter binding

I would think that the index out of bounds error would indicate that the binding has got a response/webpage that it cannot parse in the expected way.
Could be because the format has changed, could be a connection problem like a password.

OK i have also a Plenticore Plus and the same error

Status: OFFLINE - COMMUNICATION_ERROR java.lang.IndexOutOfBoundsException:Index: 4, Size: 0

Does someone have a solution for this? Password is the one i use for Web Page Access!?

Would be fine if someone can help…

Any solution on that? I have the same problem…

There could be a solution using the modbus TCP binding. I’ve tried this, but i was not able get some data…

Has anyone new infos to the Kostal binding?

BW Maximilian

Hi, i try to use a Plenticore 7 Plus via PaperUI discovery.

The thing has the state

OFFLINE - COMMUNICATION_ERROR java.lang.IllegalArgumentException:Malformed URL:

In configuration parameters i have to set a username, per default “pvserver”. According to the documentation for the new generation of Inverters you do not have to set a username. But the discovery process requests one?
I use the password set for the “Anlagenbetreiber” or “Plant owner”, for the URL i use the IP of the Inverter. Do you have any ideas?


another thread helped me to solve the problem with the Kostal Binding.

Simple solution: Upgrade to openHAB 2.5.0.M4. The Kostal binding in this version is working nice with the current generation of a Kostal Plenticore 7 inverter.


Hi, in my case it does not work with M4. Can you give me a screenshot of your settings?


I set only the model, the ip address and the password and it works…

How do you set the model? Did you use the thing “Kostal Inverter” and the thing “KOSTAL PLENTICORE plus 7.0 (no battery)”?

UPDATE: I set up a new install of 2.5.0m4 and it works. Think my current install is broken.

UPDATE2: I did a little research: When installing the Amazon Dash button binding and the kostal binding at the same time, the kostal binding crashes when adding a new thing with server error 500 in paperui.


I will add my experience to that topic and hope somebody can help me.

I have a Plenticore plus 10 (no battery) with newest firmware.

Openhab Kostal binding 2.5.0.M5

I added a Thing but I can not connect to the inverter. In the paper UI the Thing status is "Unknown" .

Someone else with same problem?

Has anyone installed Firmware: 01.40 already on Plenticore and can confirm, binding is still working?

MC-Version: 01.35
IOC-Version: 01.34

On plenticore 10 and binding is not working…
Status is “Unknown”

yes (installed firmware 1.40) and no (binding not working anymore) - details see here:

Sad, i had the same problem with the last firmware update. Used 2.4 at the time and it worked with 2.5 M4, so the maintainers of the binding did an adaption for the new firmware. But thank you for the feedback, i will wait with firmware Update.

Hey Community - someone experience with FW 1.42 already?


I got a new Kostal PLENTICORE plus 10 Inverter today.
And I want to integrate it in my openhab setup.
PI with 2.5.4-1 installed.

I installed the Kostal binding and configurate it in paper UI.
But OH will not connect to the thing.

I got a error message:
HTTP communication error: No response from device

I can connect the webpage of the inverter via webbrowser using its IP.

On the inverter there is the newest FW installed:

Type designation: PLENTICORE plus 10
Serial number: XXXXXXXXXXXXX
Article number: 10335959
UI version: 01.14.04213
MC version: 01.42
IOC version: 01.42

Made a clean OH install. And it works.
So samething must be with wrong my productive system…

Tried it (01.42) ,working fine.

Same error, any news?

I get “Wrong password”, if I enter the wrong password - so the IP is fine. Software: MC-Version: 01.57

I have done the part of the binding for Kostal Piko, Second Generation, and I have now possibilities to test the binding also connected to an Plenticore inverter.
I am right now busy to redesign the binding to version OH3.3.0, so if you Please wait until this version has been released public so can we then try to have it work as expected.
BR Basse