[SOLVED] Link to Zwave binding SNAPSHOT 2.5

@chris is the 2.5 snapshot version:
A) compatible w/ OH 2.4.x
B) Generally “stable”
C) The only way to get access to newer devices in the db? (aka, are there any 2.4.x point release of the binding that would also accomplish this?)

I think I’ve lamented this before, but it’s too bad there’s not a way to split the db portion out to a separate “binding” or piece of code (I realize it’s far too intertwined to do).

I’m not 100% sure - it’s 9 months since 2.4 was released and I think there may be some changes that require the 2.5 runtime.

Generally, I believe so.

Yes - short of rolling your own…

Yes, this is a discussion that comes up again and again. The bottom line is -:

  • openHAB doesn’t support this. To do this myself I would need to create a special configuration provider and really moves away from openHAB core features.
  • it is not guaranteed to work in any case. New features get added to Java that are interpreted by the XML files, so new options in the XML may fail. Basically, compatibility between XML is only ensured by liking the two together.

Is there a reasonably easy way to locally add a device that’s not in db?

Ya, totally get it. I’m a developer myself, so I get that while it may seem simple on the surface, until you really know the code and how it works, you can’t really assume that it can be done.

Somewhere there is an explanation by @5iver on how to edit the JAR - I’d do a search for that.

I’ve done local modifications from time to time.

Basics steps:

  1. Uninstall zwave addon
  2. Put org.apache.servicemix.bundles.xstream-1.4.7_1.jar in addons folder
  3. Launch karaf run: feature:install openhab-transport-serial
  4. Run git clone https://github.com/openhab/org.openhab.binding.zwave zwave
  5. Install apach maven (apt installl maven3, I run Opensuse so different there)
  6. Edit the xml file you need to change for instance for Fibaro Smart Implant:
  7. in the zwave addons git folder run: mvn package
  8. scp ./target/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar to your openhab addons folder or similar.
  9. You are done!

Regards, S

That should be it

1 Like
1 Like

Hello Everyone,

Greetings from Switzerland.

I am new to openhab and have a fair amount of technical knowledge on other systems.

I am struggling since the last two weeks to add a Aeotec MultiSensor 6 and a Aeotec Door and Window Sensor 7.

The Windows Sensor always pops up as UNKNOWN and the Multisensor comes up as online but does not show any readings in the Paper UI but shows:

A-Z-Wave Node 005: ZW100 Multisensor 6

Sensor (temperature)


Sensor (ultraviolet)


Sensor (luminance)


Sensor (relative humidity)



Motion Alarm


Tamper Alarm


Battery Level

-NaN %

All readings in Paper UI are NaN and for Motion and Tamper alarm there is nothing.

I have done whatever possible and am on the verge of throwing these sensors out as I am very frustrated now.

Can someone of you be kind enough to guide me on what to do to get these two sensors working.

I am running Snapshot 2.5 updated as of today.

Also can you be kind enough to give me step by step instruction on where to download the latest Zwave binding and how to upgrade it through Karaf, as I have not used Karaf before.

I await your help.

Sajive Trehan

That was handy, thanks. I didn’t seem to need the xstream jar, and everything else worked perfectly.

1 Like

Exact issue here, were you able to find solution ?

Tried/w various OH distros&binding builds…

Sehr geehrter Herr Gualty

Thanks for your message and I apologise for the delayed reply.

Yes, I was able to resolve the issue and it works fine now.

If you could describe me your exact issue then I can try to help you.

I await your update.

Vielen Dank für Ihre Kenntnisnahme
Freundliche Grüsse


Hello Sajive,

Thanks for your message. I had issue with Aeon 6-in-1 sensor, all channels reporting NaN registered to OpenHAB via Z-Wave USB stick.

Were you able to find solution ? I had to change to Smartthings hub to make it work. What did you do to make it report normal values?


Sehr geehrter Jan

Thanks for your email.

There were multiple issues.

First was that the Aeotec Z Stick cant be connected directly to the PI. It has to be connected via a USB 2.0 Hub or USB2.0 Extension Cable ONLY and it will only work then. Hope you have sorted it out.

Secondly upgrade to the latest openhab snapshot version. Unisnstall the Zwave Binding from Paper UI and install it again from Habmin.

Lastly reduce the Sleep wakeup time in Habmin Config to say 3600 secs and it should come alive in one or two hours.

Hope it works for you.

Vielen Dank für Ihre Kenntnisnahme
Freundliche Grüsse


Thanks Sajive, will try 'n let you know.


I can’t figure out where on this page I download the latest .jar file from the Jenkins site. I don’t have anything that remotely looks like a download link. Can anyone help?

Thanks for this! Worked perfectly (i also didn’t need the xstream jar).

1 Like

To download the JAR file, click on the parent folder (openHAB2-Bundles). From there, click on Last Successful Artifacts, bindings, [the binding you are seeking], [binding].jar

cue Bruce with update script link…

https://ci.openhab.org/job/openHAB2-Bundles is giving a 404 error and https://ci.openhab.org/job/openHAB2-Bundles/lastSuccessfulBuild/org.openhab.addons.bundles%24org.openhab.binding.zwave/ does the same. Is there a new link?

This seems to work now:

Hello. I am still on 2.5.11 (official what I get from apt repo) and have the known issue with Spirit Z-Wave Plus thermostat device. I would like to use the 2.5.10 version of the Z-Wave binding, but cannot find it anywhere. Does anybody have a link to the jar-file?

@chris - is there anywhere an official place, where older versions can be downloaded without having to worry about unknown and potentially malicious sources?

Updating to 3.x is no option for me, as I have spent so many hundreds of hours in my OpenHAB 2 system which I can’t (and won’t) spend again.