[SOLVED] Logitech Harmony Hub Binding - 4.15.206 firmware broke local API connection

Can you explain how to enable xmpp? I looked in all options of the android app, but can’t find it. Same for myharmony on the pc.

From the linked article by Celaeno1 :


Thanks, now i found it.

To clearify: With 4.15.250, websockets should still work with the snapshot, right?

I installed the snapshot while on 4.15.210 and it was working fine. Now my harmony hub updated to 4.15.250 too and it stopped working again. Also, I have now been getting OutOfMemoryExceptions in OH2 for a few days. Since I didn’t change anything else in my installation in the past few weeks, I have to assume there’s a connection… I just removed the snapshot again and will see if the exceptions disappear now.

There is a new issue reported here:

Thanks a lot for the link! The issue explains the behavior I see perfectly. Will keep an eye on the fix then.


Should be fixed now:

I’m on 4.15.250 and openHAB 2.5.0.M1 - and my connection is broken.
Could someone please share a newer jar of the binding?




Thanks for the heads up! Got holidays coming up, but will certainly try it afterwards.

Is there a central thread just for the Harmony Hub binding rather than the firmware is broke one here? Saw a new binding post above but wasn’t sure if that was officially a new version from the author or just something that some of the forum was playing with.



The jfrog server is an official server that does automatic daily builds from the latest official changes hence the snapshot tag. I am using the above JAR in my Openhab 2.4stable install with the latest standard firmware in the HH and it appears to be working fine in the half hour I tested it last night. Just uninstall the HH binding and then drop the jar into the addons folder and it should just work as I had the textual config files still installed.

Thanks. I have nothing right now. Unboxed my two harmony hubs, one for the TV and one for another room where the other equipment is. The one will just be used to turn the TV on and off since I didn’t buy a remote. Have a Harmony 900 that I’ll be keeping intact for now. Just starting to setup the hub so will be getting to OpenHAB shortly.



Is there a way to make a “nice” remote? Everytime I try and create a remote I always have some kind of icon and a lot of space, and only two columns. Like below:

It’s like a list of power icons. Plus it always has the dash where it would show the current active command which has no value for a volume up or down or button presses.

Also any way to do an on/off switch for the power of a given device? In this case it’s strictly a remote for my TV device. There is a powrtoggle value for the remote but not sure the best way to set it up so it has an on/off toggle.

NOTE: Got rid of the power icons with icon="" still can’t get those dashes to show the variable being called across all the dashes each time I click something. Want them to go away.



Harmony Hub with firmware 4.15.206 is running only with OH 2.5.0-Snapshot after 24th February 2019, or with the latest JAR-file (putting in addons folder).

Older OH-Versions (2.0, 2.1, 2.2, 2.3, 2.4) still have to use XMPP,
if Harmony Hub is on Firmware 4.15.250, you have to enable XMPP through Harmony APP manually.
Since snapshot “Harmony binding” supports WebSocket only!
There are also introduced two new channels: buttonPress and player, see here. --> new link

The newest JAR file (now with WebSocket and 2 new features) you always can find here (old link!):

EDIT: new link of latest JAR file.

All OH2 releases until MilestoneBuild 2.5.0.M1 (20-Jan-2019 14:09) do not contain WebSocket support!

Since MilestoneBuild 2.5.0.M2 (9-Aug-2019 12:37) WebSocket only is available.

Overview, see table:

Firmware version*** XMPP WebSocket supported OH Versions minimum Snapshot
4.15.193 yes yes 2.0, 2.1, 2.2, 2.3, 2.4, 2.5 -
4.15.201 yes yes 2.0, 2.1, 2.2, 2.3, 2.4, 2.5 -
4.15.206 no yes 2.5
4.15.210 yes yes 2.0, 2.1, 2.2, 2.3, 2.4, 2.5 -
4.15.250 no/yes** yes 2.0*,2.1*,2.2*,2.3*,2.4*,2.5
4.15.264 no/yes** yes 2.0*,2.1*,2.2*,2.3*,2.4*,2.5
4.15.280 no/yes** yes 2.0*,2.1*,2.2*,2.3*,2.4*,2.5
*=if XMPP is enabled, **=enableable through Logitech Harmony APP.
***=all firmware versions are supported through WebSocket with a minimum snapshot version, the latest JAR file or OH2 release >= 2.5.0.M2!

See also Harmony Hub Release Notes..
How to enable XMPP in Harmony APP?
Menu > Harmony Setup > Add/Edit Devices & Activities > Remote & Hub > Enable XMPP


Do websockets work locally or is it a cloud service?


It works locally.

1 Like

Maybe you edit your comment so it shows nice tables using the Markdown syntax @Celaeno1? :slight_smile:


H1 H2


Thanks for the hint. :slight_smile: Done!


Hi all,

I was running the 2.4 Harmony Hub binding and saw constant warnings in my log, so I decided to look into it a little more and found this conversation with the 2.5 snapshot. I installed it earlier tonight, and no warnings have popped up since.

@Celaeno1, thanks for summarizing at the tail end of the thread. I’ll just add that once the 2.5 binding is installed, users can disable XMPP in the Harmony app since it’s no longer required.