[SOLVED] Logitech Harmony Hub Binding - 4.15.206 firmware broke local API connection

Tags: #<Tag:0x00007fc1f4de8880> #<Tag:0x00007fc1f4de8790>

i don’t think that’s a good idea, unless your router is capable of blocking HTTPS DNS requests.
While on LAN, try to connect to https://myharmony.com for example, just to be sure.
My router wasn’t capable of blocking HTTPS DNS request.

I don’t use parental control dns blacklist but parental control no internet at all.

is there a way to block only the update connection?Block the update address or something.I dont want to block all internet access from my hub .I use it from my openhab but i use it from my google assistant too.

@Constantinos_Contis

one (or more) of these domains/ip-addresses: (see here)

Maybe you have to block all or only some of them?

54.165.126.61
54.236.3.168
54.236.3.169
54.236.3.170
100.26.13.108

svcs.myharmony.com
content.dhg.myharmony.com
logging.dhg.myharmony.com
myharmony.com
sus.dhg.myharmony.com

Does anybody have some light to shed on this issue?
Driven by the idea that Logitech was going to shove this firmware update down my throat I installed PiHole and made it responsible for DNS and DHCP in my network. IP changed for the Harmony Hub. After the downgrade I was and still am unable to reconfigure/contact the Hub.

Any input is greatly appreciated, this was one of the best integrations of OpenHAB and KNX for me.

Well, for me it did also not connect at first. Allowing the Harmony Hub to access the internet shortly after the initial boot after downgrade fixed that issue. After the first connect, I have reenabled the domain blocking for the device. It still is on Firmware 4.15.193 and can communicate with OH and Smartphone/Tablet with installed Harmony App.

Hope we will get that websocket API. This broke lots of my rules because I heavily depend on what Activity is played in the main room.
I have downgraded, turned off internet, I couldn’t use the mobile app and also refused to connect to openHab. Re-enabled internet, everything worked for a few hours, then update happened automatically…

Is it possible, to prevent the hub from updating by blocking it within my fritz.box router? When I use the Network settings of the fritzbox, i can configure for the ip-Adress of the hub within my homenetwork a called “Zugangsprofil gesperrt”, which hopefully means no access of this device to the internet.

Anyone tried this before?

Thanks

Claudio

I am using exactly this with my Fritzbox 7490. This locks down the internet for that device.

Thank for the quick answer. Than I will downgrade today and use this feature. I hope, that Logitech is not blocking that downgrade feature, before I downgraded my device…

Claudio

Yes, this is absolutely possible. Just give it a moment after downgrade and startup to initially connect (otherwise it won´t initialize completely). After your remote can connect (or it shows up in OH as online) you can block internet access via Internet -> Filter -> Listen -> Gesperrte Internetseiten (Blacklist).

I added these domains:
myharmony.com
svcs.myharmony.com
content.dhg.myharmony.com
logging.dhg.myharmony.com
sus.dhg.myharmony.com

Afterwarts I created a new access profile at “Zugangsprofile” with setting
“Filter für Internetseiten” enabled and “Internetseiten sperren” checked.

The last step is to assign this access profile to the harmony hub device in tab “Kindersicherung”.

The steps above are for a Fritz!Box 7390 with Firmware 6.85.

Best regards,
Rainer

@dr_vergleich

Me too. It’s a “Fritz!Box 6490 Cable”. I also set “HarmonyHub” to “gesperrt” (=blocked).

–> No firmware updates from Logitch!

P.S: Check your DHCP settings for “HarmonyHub” if “provide always the same IP-Address” is activated!

Let’s see if this really blocks it. Also have the 6490 and blocked internet use completely for the hub. Hopefully logitech reacts and re-enables local access.

Logitech has released a special developer firmware. This one opens XMPP again. You can find it within the same tool used for the down-grade. For me it worked very well.

=> FIRMWARE TO ENABLE XMPP. FOR DEVELOPERS ONLY.

12 Likes

Thanks for sharing. I’ll try later at home.

Looks like the community put enough pressure on Logitech :+1:

trying to update to xmpp firm but i get a blank white screen when i press “Update Firmware”…

For me it worked very well. THX

Many thx, worked fine for me too :slight_smile:

Merry Christmas

I had the same issue. I was running an older version of the MyHarmony application. You should download the latest version. It seems they updated the application framework to use .NET instead of deprecated Silverlight although it looks exactly the same.

1 Like

many thnx mate !!!