[SOLVED] Logitech Harmony Hub Binding - 4.15.206 firmware broke local API connection

Really? Or is it ironic and I missed the point?

I personally feel, they made it the wrong way. Just the pressure the open source community put on the company, the bad headlines in the tech magazines etc. have lead to change it back and re-enable the api.

Initially they seemed not having the intention giving us the local access to our paid devices back.

We have to be grateful to the the open source community and home automation enthusiasts which created that pressure.

Thank you, community!

2 Likes

just installed the dev firmware, worked fine, thanks to all your efforts.
greetings Andy

Logitech just released a firmware 4.15.210 that re-enables the API. They say they don’t recommend it but you have the option to get back to business. (Alt + F9 -> scroll down the page to the last option “Firmware to enable XMP”).
It works now!

what a piece of …

I was travelling for one week and got back and found my hubs not working anymore. OK, found the temp solution to install dev firmware, good. But then I wasn’t able to install harmony desktop software because faulty installer and wrong file permissions to AppFiles.zip

This fixed it for me (scroll to the bottom, last posting)

https://community.logitech.com/s/question/0D55A000078qWqlSAE/cannot-run-harmony-desktop-app-to-configure-650-remote-err-a1005

https://community.logitech.com/s/question/0D55A00008D4bZ4SAJ/harmony-hub-firmware-update-fixes-vulnerabilities

Thanks, seems to work :slight_smile:

Same here beta binding working fine for me.

I don’t think this developer version of firmware will last.

I hacked together a python mqtt to websockets server and moved my items over to mqtt. Works well.

The websockets interface is actually quite easy (returns/accepts json).

I’ll stick with my hack until the new Harmony websockets binding is ready.

I just hope Logitech don’t take it into their heads to disable the websockets interface at some point.

I just disabled the internet access for the damn thing in the fritzbox configuration

1 Like

I can confirm I am experiencing the same problem.
The Developer XMPP firmware option solved it for me as well.

I can confirm this too. Works like a charm after activating the developer Firmware! Thanks for pointing that out! As this is the latest firmware, deactivating internet access should not be necessary either. Seems to be the best workaround in the moment.

Installing the developer version 4.15.210 worked for me also. Downgrading to the version prior to .206 was driving me crazy as my system kept automatically “upgrading” me to .206, which of course I didn’t want… Since .210 is a higher level, the upgrade process is now leaving me alone!

Here also. 4 x Harmony Hub with latest firmware ‘XMPP’ upgrade and no further problems experienced for so long.

Thanks for the information, worked well for me.

Great, thanks!!

Just to confirm that with the beta firmware works great! Thank you

1 Like

I’m still waiting for this: (link)

Logitech - Smart Home Group
Edited December 21, 2018 at 7:20 PM
“If you would like to participate in an XMPP beta program, which will allow access to local controls, see the below instructions. Over the coming weeks, we will qualify a regular firmware release that still allows XMPP control for those who need it. We expect to send out an update that will be available to all Harmony customers in January (2019).”

Is it still planed to upgrade to websocket?
Are there any progress update to this.

Currently Logitech Updates für firmware to enable xmpp again BUT there is a high security risk to this and you have to agree to loose all support

@renier

You can try this version:

It uses the websocket connection.

1 Like

Will try,

Thanks for pointing to this.