[SOLVED] Logviewer error in web ui

Good morning

Having some issue with viewing the log viewer in web ui for a while now. Just done a full apt update so thought I’d finally get the issue resolved.

Running 2.4.0-1 on raspberry pi 3

The file the logviewer is trying to view is /var/log/openhab2/events.log

And the browser comes up with crashed.

Tried to follow a solved issue thread by reinstalling logviewer by openhabian-config which says it’s installed ok.
I then check systemctl status fronttail and it responds with no service found.

Any advice would be much appreciated I’ve probably missed something very simple!

Have you stopped OH and rebooted since the update? Are you running OH on an SD card?

I have rebooted the pi completely after the update. And yes I’m running it off a sd card

What is the output of ls -al /var/log/openhab2

total 14848
drwxrwxr-x+ 2 openhab openhab     4096 Dec 21 23:19 .
drwxr-xr-x  8 root    root        4096 Jan 26 06:25 ..
-rw-rw-r--  1 openhab openhab        0 May 28  2018 audit.log
-rw-rw-r--  1 openhab openhab 14399704 Jan 26 09:22 events.log
-rw-rw-r--  1 openhab openhab   660372 Jan 26 03:23 openhab.log
-rw-rw-r--  1 openhab openhab   117362 Dec 21 23:18 openhab.log.old
-rwxr-xr-x  1 openhab openhab        0 Dec 17 08:01 Readme.txt```

Permissions look good. I installed OH via openhabian image and I have openhab:openhabian so maybe try using the openhabian-config tool and select Apply Improvements then Fix Permissions and System Tweaks to see if anything changes.

1 Like

Not sure which one worked because I didn’t check in between but that has solved it. Thank you

Glad it’s working.:+1:

Thanks for marking the topic solved.:smiley: