[SOLVED] [Main] Konnected Binding

You can ping me back here in this thread. I check into the forums on a regular basis and I get notifications on this thread in particular.

1 Like

So I got the manual binding installed and its dependency and the modules connected to my network and assigned a static IP, but when I go to add the Konnected module to openHAB it says “ERROR: 500 - Internal Server Error”. Not sure what I’m doing wrong.

https://pastebin.com/T1pKtjj6

Here is the log. I’ve tried everything I could think of to get it working, granted I am a noobie.

@volfan6415

question once the thing is added and the channels created does the error persist when openhab is restarted?

Also thats the just the error message can you upload the entire log file. Thanks

I added the module in paperUI and created a channel with ID zone1 as specified in the readme, its a buzzer so I made it as an actuator. The konnected module things status is “Unknown” before and after restart. When I test the buzzer it does not respond. When I add the Thing through paperUI the light does not blink on the module ether.

I can give you a step by step more detailed if it will help you see what’s going on. Also attached is my full log.

events.log
https://puu.sh/BX4Xp/63a4b5f3c9.log

openhab.log
https://puu.sh/BX4XN/050a1a39a3.log

Thanks for the logs. So in looking through the logs it does not look like the binding is starting properly because of a missing requirement of the upnp service. Can you please run feature:install openhab-transport-upnp from the karaf console and then restart the openhab service.

I thought I did install that. I did the command again and to confirm I checked the feature list to make sure it was installed and running. After doing that I tried to connect the module again, no cigar. I also made sure UPnP was enabled on my router, is was.

Here is the new fresh log file what happened.
https://puu.sh/BXdQu/d2fa2b099c.log

Ok so that shows that the eclipse upnp feature is running but in your openHAB feature list do you have another feature that shows that the openhab specific upnp feature is also installed?

This is the line from my karaf console:

The binding depends on the openhab version of the service specifically as opposed to the eclipse smarthome version of the service so make sure that you installed the correct dependency in the karaf console.

From the logs that you posted i can’t see where the binding was starting as it looks like these are truncated again (the logs delete after awhile so if you uploaded the file after the service had been running for awhile i wouldn’t have expected to see the start up info). But the error messages that are being thrown are the null pointer exceptions from the framework trying to find the handler which likely indicates that the binding is still not starting properly.

Verify that you have the above service installed in the karaf console. Then restart openhab and send a copy of the log file so i can see the start up logs as well.

Also what version of openHAB are you running?

Ah crap, really sorry about that. I did verify the first time around that the right feature was running but when I screenshotted I must have went too fast. The right one is installed, just so happens that one is installed too.

I am running 2.4.0-Snapshot for windows. Here is my current log file, it ran overnight and through a few restarts. https://puu.sh/BXszt/0b2eae4117.log
I’m going to play around and see if I can get it to work by reinstalling the binding or something. :thinking:

EDIT:


I uninstalled the binding, cycled the openhab instance once for shitz in gigz, then reinstalled it, its running now. I tried to set up a module again and still throwing errors. It looks like its failing to send the config to the modules. Below is the config after my uninstall, cycle, reinstall, and attempt.
https://puu.sh/BXt4D/f2c250c034.log

Can you up the log level of the konnected binding to trace via

log:set TRACE org.openhab.binding.konnected in the karaf console the restart openhab and upload that complete log file

It looks like it is set to the default level which is not letting me track all of the error messages that are possible. Once you do that then i can see a complete log set of the binding attempting to start and can see what values are potentially throwing the error in the config check.

On a positive note it looks like in looking through the logs that the bindings is starting now as things are showing up in the inbox!

2018-11-06 14:34:26.889 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘konnected:module:4512915’ to inbox.
2018-11-06 14:34:26.903 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘konnected:module:13302072’ to inbox.

Question did you also delete and recreate thing via the inbox discovery result during the reinstall? It should not have mattered but curious?

They have been going to the inbox, so nothing changed there. To be honest the only difference so far is that I verified that the binding and dependencies were running, I did run those commands when I first installed the binding addon.

I set log to trace, attempted to add module.
https://puu.sh/BXusc/755c25b204.log

Yes, I delete and recreate each time.

Hey thanks for testing and the logs. I think i have found where the bug is There was an issue with my code that I need to fix. I will get the changes made and push the changes with a new jar you can download later tonight. (i am in central US time)

1 Like

You’re awesome! Thanks for working with me to figure that out. Nothing ever just… seems to work the first go. :laughing:

And when it does, you’re looking around for what exploded.

1 Like

New version uploaded into the pull request with a new jar. I think this should auto update into the marketplace. But if not you can also download the version that is in the first post of the pull request.

Once you have installed that version let me know if you are still getting the error messages

Seems like its still not working. :cry:

https://puu.sh/BXG5U/55e82d3a9e.log

Ok now i have found the bug! I have reproduced this on my system and I am working on a solution.

1 Like

xD

I’ll be watching the thread for when you come up with a fix, i’ll test it for you.

2 Likes

think i found it. I had added some things last minute in that i did not debug as well as i should have and that is what created the bug. I have been using a slightly older version on my production system hence why i didn’t notice it. But just pushed the changes up to github in the pull request and it is rebuilding now. Are you using the marketplace install? Or the jar from the pull request?

I should add that i was able to reproduce your error on my system with the code and now the error is gone and the code is working on my system. So please test on your system with the trace logging on. Clearly want to make sure there aren’t other bugs i need to squash out. thanks for your patience.

Just curious.

1 Like

I am grabbing from jar link at the top of the pull request. I checked the timestamps and byte size just to make sure last time.