[Solved ]Manually restore openHAB from backup.tar.gz

Hi guys,

:see_no_evil: actually my server SSD with all my lxc-containers died…

the openHAB container was a Debian 11 distribution of Linux.

I regularely made backups from my containers using tar - so luckily I have a nearly actual backup of the entire rootfs. I used openHAB 3.3.0.M2…

I searched the forums how to restore my openHAB configuration but mostly I found threads about using the backup/restore function from openhabian. I haven’t found the information needed to restore my openHAB manually.

My Rules are file based so this is a nobrainer to restore - but I’m very unsure how to restore the DB…

My first idea was to completely overwrite all files in

  • /etc/openhab/
  • /var/lib/openhab/

with my backup files… but I don’t know if there are any unique IDs generated from openhab when installing and a simple overwrite can cause inconsitency.

Any experienced Linux users here which can provide a good way to restore my settings without messing everything up?

I can’t restore the whole original container because I created it with LXC4.0 and now I switched to LXD and used that to create the new containers. Mainly because it’s more confortable and provides snapshotting…

Edit: another idea would be to install LXC4.0 and add the old container’s rootfs - Is there a way to use the backup function from openhabian in Linux?? If so I could take a backup, uninstall LXC4.0 and restore the backup to the new LXD container?!? Just a thought…

Have a look Info the restore/backup function/script that comes with OH.
They are Shell scripts and you should be able to understand them and re-use them in your setup.
They are caller from with in openhab-cli.

1 Like

Hi, thank you Wolfgang - sounds promising… I post my progress in this thread :slight_smile:

:smile: ok

first I restored my influxdb and mosquitto containers to match my openhab config…

but then I went quick and dirty :see_no_evil:

I simply deleted the content of

  • /etc/openhab
  • /etc/openhab-cli
  • /var/lib/openhab
  • /usr/share/openhab

then copied the backup content to the empty folders

changed the ownership of all files to openhab:openhab

and gave it a try :rofl: and what should I say…

It’s almost running - the only thing which remains a black page is the webUI but I can use my smartphone for now as long as I’ve not figured out what went wrong with the webUI… but I’m glad to have this result at least. My smartphone renders the content normally - omg I didn’t even cleared the cache folder…

:sweat_smile: no pain - no gain

it got late here - have to go to sleep…

1 Like

Update :blush:

seems like it’s an https problem that webUI didn’t show up…

I used to connect via


this isn’t working (i get a blank page)

but if use a http link instead


everything is back to normal :sweat_smile:

btw does anyone know where I can re-enable https support for the webUI - I can’t remember where to change this…

Edit: I’ve found the solution - it’s documented >here<

I think this thread is solved :blush: