[SOLVED] Map transformation issue


Recently i installed map transformation. When i try to use a simple transformation like:

Number D_Rain                         "[MAP(rain.map):%s]"              <rain>                                                 { knx="1.002:1/0/6" }

the following appears in the log:

2017-01-08 00:17:21.908 [WARN ] [.core.transform.TransformationHelper] - Cannot get service reference for transformation service of type MMAP
2017-01-08 00:17:21.909 [WARN ] [ui.internal.items.ItemUIRegistryImpl] - couldn't transform value in label because transformationService of type 'MMAP' is unavailable

What about that leading ‘M’ on ‘MAP’ ? A register issue?

i use a recent snapshot of oh2 > 2.0.0~20170107181629


There is an issue for that on GitHub. There also exists a Patch, but it is not yet merged. As a workaround change your label to something with a non-space Character before the [

1 Like

It’s working, thank you!

I have the same problem.

Group:Switch:OR(ON,OFF) Alarm "Sécurité[MAP(alarm.map):%d]" <alarm> (All)

Does not work with openhab.android. But works very well with basic UI, classic UI …

cat transform/alarm.map

You see the error log Cannot get service reference for transformation service of type MMAP ?

I think you might try with a space at [

Group:Switch:OR(ON,OFF) Alarm "Sécurité [MAP(alarm.map):%d]" <alarm> (All)

Indeed, your synthax is better. I have no error in the log, just openhab.android does not display the sitemap because of this item.

No problem with basic UI and classic UI.

Okay, no error log so not the same at all.

You have a sitemap that doesn’t display on android, what makes you suspect that is because of this Item?

With this item Alarm, the site is not displayed. If I change by
Group: Switch: OR (ON, OFF) Alarm "Security" <alarm> (All)
The site is displayed and works correctly on android openhab

Same error after upgrade from OH2.0.0 to OH2.1.0. The android app is not working anymore. No problem with classic and basic UI.

This item was working fine with 2.0.0

Group:Switch:SUM gSuperior "Bedroom [MAP(number.map):%s]" <bedroom>

I used to have item and sitemap defined like this (and it was working fine with habdroid on OH2.0):

Group:Switch:SUM gSuperior "Bedroom [MAP(number.map):%s]" <bedroom>

Text item=gSuperior

After upgrade to OH2.1 the above example stopped working on habdroid.
To work with habdroid I had to change my item and sitemap definition to this:

Group:Switch:SUM gSuperior "Bedroom" <bedroom>

Text item=gSuperior label="Bedroom [MAP(number.map):%s]"
1 Like