[SOLVED] MAP Transformation not available

I have had trouble getting the MAP transformation service working. Tried through the PaperUI and then setup the addons.cfg file with the right bindings, and transformation service, but still see the following errors:

[rest.core.item.EnrichedItemDTOMapper] - Failed transforming the state ‘NULL’ on item ‘FF_LaundryRoom_Door’ with pattern ‘[MAP(door.map):%s’: Couldn’t transform value because transformation service of type ‘[MAP’ is not available.

# A comma-separated list of transformation services to install (e.g. “transformation = map,jsonpath”)

transformation = map

Just ran openhabian-config and updated to the latest release.

Thanks for any help.


Maybe you missed the close bracket?


Could Be Like this

‘FF_LaundryRoom_Door’ with pattern ‘[MAP(door.map):%s]’:

My MQTT example

1 Like


To be sure, use the following commands in karaf console:

feature:list | Grep openhab-transformation-map
feature:list | Grep esh-transform-map

This should be displayed:

openhab-transformation-map                  │ 2.5.0.SNAPSHOT   │ x        │ Started     │ openhab-addons-2.5.0-SNAPSHOT        │ Map Transformation
esh-transform-map                           │ 0.11.0.SNAPSHOT  │          │ Started     │ openhab-addons-2.5.0-SNAPSHOT        │ Map Transformation


Thanks for the clue on where to look. I had not one but two brackets causing the issue. Interesting that VSCode did not highlight the syntax error.


1 Like


Tick the solved mark, please. Maybe other users find this also helpful.