[SOLVED] MariaDB-Persistence no data despite connection to DB


at the moment I have a problem with the database connection.

What I have done:

  • Installed JDBC Persistence MariaDB (PaperUI)
  • Configured jdbc.cfg:
tableNamePrefix=Item #(Cause of a hint in another thread)
enableLogTime=true #(To debug)

And here’s my jdbc.persist

Strategies {
	everyMinute : "0 * * * * ?"
	everyHour : "0 0 * * * ?"
Items {
computerstatus1 : strategy = everyMinute, restoreOnStartup
Repeater01_LatencyMS : strategy = everyMinute, restoreOnStartup


And here are the logs:

JDBC::openConnection: Driver is available::Yank setupDataSource
JDBC::query: unable to find table for query, no data in database for item 'computerstatus1'. Current number of tables in the database: 0
JDBC::query: try to generate the table for item 'computerstatus1'

The table was created successfully but they are empty. I already read already the other threads to this topic but that didnt work.
It would be great to get some help from you - Thank you

EDIT: Nevermind - But it works now. Honestly I dont know why it works yet…

Sometimes changes at persistence-configuration need a oH restart.
Please mark as solved.

Sorry for the dumb question, but how can i mark this thread as solved?


1 Like