[SOLVED] Max Binding (maxCube) changes temperatures unwanted!

I’ve still problems with my maxCube setup as already pointed ouit here:
(MaxCubeBridgeHandler - IO error occurred during execution: Read timed out)
I thougt that I solved the problem, but still struggling with “not triggered” changes of temperatures…

If the binding maxCube is active (or more precise the bridge) obenHab changes some room temperatures “on its own” after some time? I don’t have any rules, just thing, items, sitemap.
I’m working with files, but also tried using paperUI, same problem.
All thermostats are in “manual” mode and if openHAB ist off or the cube bridge not active, everything seems to be fine.

I’m running on OH2.4 stable with the actual binding:
240 │ Active │ 80 │ 2.4.0 │ MaxCube Binding

The trace shows me some commands like this one:

24-Dec-2018 14:54:32.682 [DEBUG] [.binding.max.internal.handler.MaxCubeBridgeHandler] - Command org.openhab.binding.max.internal.handler.SendCommand@9373b6[id=329,channelUID=max:thermostat:Cube:Schlafzimmer_Re:set_temp,command=23.0 °C,cubeCommand=<null>,serialNumber=JEQ069XXXX,key=JEQ069XXXX-set_temp,commandText=23.0 °C] sent to MAX! Cube at IP: XXX.XXX.X.XXX

The last real command was hours ago by manual changing the temp via sitemap:

24-Dec-2018 08:18:16.938 [smarthome.event.ItemCommandEvent ] - Item ‘maxSetTempSchlafzimmer_Re’ received command 18.5
24-Dec-2018 08:18:16.941 [smarthome.event.ItemStatePredictedEvent ] - maxSetTempSchlafzimmer_Re predicted to become 18.5

=> the temperature switches from 18.5 to 23°C

The time seems not to be constant, sometimes it’s quicker and sometimes it takes a little bit longer.

How could this happen? And what can I do?

Any ideas ?

The cube as a thermostat controller is still active. Check what’s configured in there.

Please check with original “Max! Software” if there is the scheduler still active. If not, could it be that someone else in your house/flat has changed the temperature manually, direct at the valve’s wheel?

The original max scheduler is active, but should only work in mode “Auto” correct ?

Without openHAB, the thermostats working without “surprise”. As the mode is set to Manu, all temperatures stay constant (exception: open Window)

I’ll try again with adding the thermostats Thing by Thing and find out when the unwished tempchange happens. I’ll start with the first room with two thermostats.

but this is a long journey and nothing I enjoy doing…but I don’t have ideas to find the root cause…


Yes, this is correct!

Do you have a rule in OH, that sets the temperature to 23° C?

No, there is no rule in openhab for the max thermostats. Only “watching” with grafana…

I’ve added the thermostats step by step. No big surprises with 5 thermostats, now i added the last room with 3 Thermostats. Will see what happens…

What I saw was something I already watched in the grafana charts but didn’t have time to have a closer look:

some thermostats get a new temperature 0.5 °C higher and down again:

is this a “known” behaviour ?


I found something in the logs regarding the 0.5°C swap:

27-Dec-2018 22:43:34.567 [TRACE] [.binding.max.internal.handler.MaxCubeBridgeHandler] - Command org.openhab.binding.max.internal.handler.SendCommand@ef1feb[id=37,channelUID=max:thermostat:Cube:Bad:set_temp,command=22.5 °C,cubeCommand=,serialNumber=JExxxxxx50,key=JExxxxxx50-set_temp,commandText=22.5 °C] completed for MAX! Cube at IP: xxx.xxx.x.xxx

27-Dec-2018 22:45:33.617 [DEBUG] [hab.binding.max.internal.handler.MaxDevicesHandler] - Finished Actuals Refresh: Restoring Temp 22.0
27-Dec-2018 22:45:33.621 [DEBUG] [.binding.max.internal.handler.MaxCubeBridgeHandler] - Command org.openhab.binding.max.internal.handler.SendCommand@193d04e[id=38,channelUID=max:thermostat:Cube:Bad:set_temp,command=22.0 °C,cubeCommand=,serialNumber=JExxxxxx50,key=JExxxxxx50-set_temp,commandText=22.0 °C] sent to MAX! Cube at IP: xxx.xxx.x.xxx
27-Dec-2018 22:45:33.622 [DEBUG] [.binding.max.internal.handler.MaxCubeBridgeHandler] - Command queued id 38 (JExxxxxx50-set_temp:22.0 °C).

while writing the above post, it happpens:

temp is switching from 16.5°C to 22.5°C and ~2 min later down to 22°C

nobody in the room and no rule active…
(update of the 3 last thermostats was a little bit later
27-Dec-2018 22:46:05.910 [INFO ] [.smarthome.model.core.internal.ModelRepositoryImpl] - Refreshing model ‘max.things’)

one of the thermostats of the sleeping room has now the same temp as the thermostat of the bathroom…

I had a similar problem (years ago). Two thermostats switched each other or in parallel. I removed both completely from Max!Cube. Then I did a factory reset of both thermostats. Then I added them with other names back to Cube. Then the error was gone forever.

Good hint, didn’t even know that I can reset the thermostat. I did a reset of all 8 thermostats.


thx, that helped! Since two days no suprises!

Only the 0.5°C “Jitter” is still on some channels ? Is this normal ?

Sorry. I don’t know about this. I never had this problem.