[SOLVED] MIIO Powerstrip issues

This is a strange one.
I have had my QMI PowerStrip (5 socket) previously working for many months then around June/July this year it fell off the network and I had to reset it and get it reconfigured. Since then It has not worked correctly at all.

As I recall it used to identify itself as a QMI powerstrip v1 and it was listed as unsupported, but I was able to use channels for getting the power rating in watts and turn it on and off and I believe the internal temperature was also provided.

now it does not set the model identifier and it gets seen as generic without the power usage channel and none of the channels actually function.
I suspect thats because I am seeing this in the debug log and yet it shows as ONLINE.

2018-11-11 20:08:36.003 [DEBUG] [ing.miio.handler.MiIoAbstractHandler] - Received response for 02F1E7DC type: MIIO_INFO, result: null, fullresponse: {"error":"Given final block not properly padded. Such issues can arise if a bad key is used during decryption."}

2018-11-11 20:08:36.003 [DEBUG] [ing.miio.handler.MiIoAbstractHandler] - Error received: "Given final block not properly padded. Such issues can arise if a bad key is used during decryption."

I think the token is correct, is there another reason I may see that log entry?



Anyone have any ideas?
@marcel_verpaalen perhaps?

As you have reset the device, the token also get reset.
It will only get the right channels once there is successful communication and the binding knows which model it is, hence can enable the right channels.

suggest to downgrade th android app, extract the token again and try to get the padding error away (=token error). Once the connectivity is working, I expect it should now recognise your model.(if not, let me know and I can add it to the db)

I do not think its possible to downgrade the IOS app.

I use the itunes db file backup and extract method to get the token.

I can PM you the full line from the db extract if that will assist with the device model declared?



I have grabbed the token again for the power strip and it now works, well to a degree.
let me explain, It no longer complains in the OH logs that it has the wrong token. I do notice that if I use the short token on the miio command line app it says its error but the binding seems happy with it.