[SOLVED] Minimote Unknown Device

I just started setting up an OpenHab 2 server on a Orange Pi Zero. All devices worked on a Vera Light box. The package installation of OpenHab i used is on version 2.3.0. I’am using the Aontec Z-stick gen5 and included a couple of devices. Mostly Fibaro relay switches. The work all perfectly.

But i’am struggling to get the minimote to work nicely. It is paired with the stick. All leds blink like they should. But in paperUI it keeps listing as Unknown. I dug through the whole forum but couldn’t come up with an answer.

The wake-up buttons gives log-lines. When i press a button i get lines in the log saying data is received. It even list the scenes numbers. But it keeps popping up as an unknown device.

I’am doubting if the device database is correct. How can i list the manufacturer and device id of a paired device so i check it against the database? And, if i need to, how can i alter it?

Help is much appreciated.
I hope my English is good enough…

Greetings Erik

Of all devices, I’ve found the Minimote to be the most difficult to include. Although my Minimotes are working, I’m currently dealing with some oddities with mine…

  • My first suggestion would be to use the latest version of the development Z-Wave binding. In a few weeks this development version will become the master, and will be included in future OH distributions. Please read the first several posts on this topic.
    OH2 Z-Wave refactoring and testing... and SECURITY

  • I also would suggest you use HABmin to manage/configure your Z-Wave devices. HABmin can be installed through the Paper UI.

  • Make sure your Minimote is on the latest firmware version, 1.1.9, I think.

  • You might need to exclude and include the device a couple times before it’s properly identified.

  • Once discovered properly, you need to change the mode from Group mode to Scene mode. Making this change will cause the Minimote to send SCENE_ACTIVATION commands (which I think is what you want).

  • I’d suggest tagging your posts with the zwave tag, as it will make it easier for people to identify it as being related to Z-Wave. There are several people who track the zwave tag, so anything with that tag will show up in their Unread list. :wink:

@chris Did you have a chance to look at the Minimote logs I emailed to you last week?

@5iver Is there anything you want to add here?

I would bet that the version of the binding distributed with 2.3 will suffer the same issues we discovered recently (same as @vanE is describing). So a recent snapshot or the dev version of the binding would be needed in order to get the binding to recognize wakeups and complete initialization. The process would be the same for both… including deleting (not exclusion)/rediscovering the minimote Thing.

Thank a million. It worked.

The MiniMote has been detected and initialized. Steps taken:

  • Installed the last zwave-binding update from cloudbees.
  • removed the serial controller
  • added a new serial controller
  • scanned the inbox

One weird thing i get in the console when i list the bundles (bundle:list -s |grep zwave) is:
231 â Active â 80 â â org.openhab.binding.zwave
239 â Installed â 80 â 2.3.0 â org.openhab.binding.zwave
Why is the 2.3 installed and 2.4 active? Anyway it seems to work.

During the scanning of the inbox i held the learn button of the minimote. That seems to have done the trick.

But… When i look at the network viewer. The minimote isn’t connected. It also doesn’t send any signals. At least they don’t show up in the logging (debug-level). Yesterday i have seen logging from the minimote. But after all the fumbling around there gone. I thought it had to do with the controller being node 1 but that’s not the case. The controller is no 1.

With all the including and excluding i now have 4 unknown devices somewhere in the buffer of the z-stick. Is there a way to get rid of them?

Note that this is not the development version of the binding. I don’t believe @chris is doing anything other than database updates on this binding because it’ll soon (couple weeks) be replaced by the development version of the binding. Once the dev version becomes master, when you replace your zwave version with the latest version from Cloudbees, you will need to delete and rediscover your node Things. One thing I’ve noticed on the dev version is that the node heal process, which runs nightly and at initialization, has made my network more reliable.

It is helpful to use code fences for this type of data. Much easier to read.

231 Active 80 org.openhab.binding.zwave
239 Installed 80 2.3.0 org.openhab.binding.zwave

The original version of the zwave binding that you installed probably is still cached by openHAB. You can resolve that by doing the following:

  • stop openHAB
  • remove the contents of openhab2/userdata/tmp and openhab2/userdata/cache. Don’t remove the directories; just remove the contents of the directories.
  • start openHAB

Yes, this causes the MM to wake up, which allows the binding to talk to it.

None of my MMs are connected to anything either.

I’m not exactly sure what you mean by signals. The MM doesn’t wake up on its own. The only way to make it send messages is to wake it up (like you did), or press a scene button. When you press a scene button, you should see the SCENE_ACTIVATION command class in the debug log. You might want to become familiar with Chris’s log viewer. It’s much easier than reading log files. :wink:

If you delete the node Things using HABmin, then run discovery (the little search icon in HABMin), are they still there?

I’ve got i it all up and running. It almost drove me mad. It’s a bit confusing with all different UI’s, places to get packages, etc…

I think I’ve got the development release. In the post you pointed at, was a link to a 2.1 version. I altered the link and got a 2.4 version. That one worked but took a bit of guessing. For future reference, how can i make a .jar from the downloaded git version? I tried to make a .zip from the downloaded source but that didn’t work although it look the same as a authentic .jar file…

After a restart the system it all kept working. One thing i’am not really confident about, is the zwave binding. In PaperUI it still shows up as the 2.3.0 version. In the console it’s not showing at all.

openhab> bundle:list |grep zwave

The serial controller no more lists as a Serial Controller but as a Zwave Plus USB Dongle. The Serial Controller is still available thou ???

After deleting the unknown device, they still keep turning up in the inbox.

One other question which keeps puzzling me. What is the best way to configure Items. At first i created .items files like this:

Dimmer Dimmer_Keukentafel	"Dimmer keukentafel"	<dimmer>	 { channel="zwave:device:512:node14:switch_dimmer"}

Later i connected the Items with the Things in Habmin. That lead to double links? Now i commented out the channel part of the .items file. Is that the correct way?

As i said before it’s a a bit confusing and i’am still not really confident i’am building a reliable system. I know my way around an a Linux system and i’am a programmer (being VB.NET, but still :grin:). Although with your help i think i’am getting there. Thanks

Try this

bundle:list -s | grep zwave

Or just this

list -s | grep zwave

Post the version you’re running and we’ll be able to tell if it’s the dev version.

When you go to this link, you will see this. Clicking on here will get you the dev version.

That’s just the name it gets when it’s discovered.

In HABmin, you can try removing the device from the controller. Select the Thing, click on Tools->Show Advanced, then Set Device as Failed and/or Remove From Controller. Note that I’ve found this to work sometimes, and not work other times.

You can do it either way (but not both at the same time for the reason you discovered). I use Items files for all my items. I have multiple items files (e.g. I have a zwave.items file for all my zwave devices), but there are other ways to do it.

You would need to install and setup an IDE and compile it.

The controller stores the devices that are joined to the network. Deleting the Thing will not remove it from the network, so when you rediscover or restart the binding, it will show up again, since the binding is reading the devices from the controller.

In your items file, this…

{ channel=“zwave:device:512:node14:switch_dimmer”}

is the link to the channel. Nothing more is needed. You may want to go back and remove the double links in a UI, as it could cause issues. If all your items are defined in files, you could run smarthome:links clear in Karaf. This will remove all of them, but since the links are in your files, they will come back when you restart OH. Or the ones that came from items files won’t be deleted, I don’t recall. Either way, it will quickly clean up the duplicates.