SOLVED: Mios binding transform not working...ideas greatly appreciated:-)

Hi,

I have searched the forums for ideas, but to no avail, so I hope some of you can assist me a little bit:slightly_smiling_face:
I am trying to setup the Mios binding and have the house.items file generated and the MAP files in the transform directory - everything looking good, except for the fact that there is no connection between my Vera and openHAB.
I have taken 3 z-wave items and inserted into my sitemap for testing - 1 temp. sensor, 1 motion, 1 door.
The log tells me that the transform is not working:

2018-01-27 20:58:11.085 [WARN ] [rm.AbstractFileTransformationService] - Could not transform ‘-’ with the file ‘miosDeviceStatusUI.map’ : Target value not found in map for '-'
2018-01-27 20:58:11.098 [WARN ] [rm.AbstractFileTransformationService] - Could not transform ‘-’ with the file ‘en.map’ : Target value not found in map for ‘-’

As far as I can understand the “-” means “no value”. Does that mean that the vera is transmitting “no value”? The vera seems to be working fine.

Number   TemperatureSensorCurrentTemperature "Temperature Dining [%.1f °C]" (GDevices,Dining) {mios="unit:house,device:46/service/TemperatureSensor1/CurrentTemperature"}
Contact  MotionsensorTripped "Motion sensor [MAP(en.map):%s]" <motion> (GDevices,Dining, gMotion) {mios="unit:house,device:45/service/SecuritySensor1/Tripped"}
Contact  DrsensorHoveddrTripped "Drsensor Hoveddr Tripped [MAP(en.map):%s]" <contact> (GDevices, Entryway, gDoor) {mios="unit:house,device:33/service/SecuritySensor1/Tripped"}

These are the items i have inserted in the sitemap (for basic UI), where they show as expected but with no values.
As you can hear from the above I am a total rookie, but seeing endless opportunities in openHab so any inputs/ideas you might have to what I am doing wrong are greatly appreciated.
Thanks:slight_smile:

It looks like you did everything right. The only thing I noticed that you didn’t mention was the mios.cfg file that points OpenHAB to your vera IP address.

Hi Mike,

Thanks for your reply.
Yep I forgot to mention but i have set up the file like this:

house.host=192.168.1.69

Is that the correct format?

That’s the same format that I have. Do you have both the Mios Binding and the Mios Action installed?

Not the Mios Action. Is that also required?
I´ll try and install that right away.

I’m not sure it’s required or not, but I have it installed on my system. I was looking back on some of the posts I looked at when I was trying to get it to work. The person who wrote the binding (guessed) mentioned that you need the right version of Java installed.

Awesome:-) I just installed the Mios Action, and 1 second later all the values (door, motion, temp) populated and is working perfectly!
Thank you very much for your help - so nice to get this going!

Cheers,
Peter

I also read about the Java version and had already tried that, but that did not help in this case.

Great! Glad you got it working. I know how you feel. It can be frustrating. I am not expert at this either