[SOLVED] Missed UI install - no access to paperui

  • Platform information:

    • Hardware: Pi3
    • OS: openhab 2.3.0-1
  • Issue of the topic: Skipped ui install

How can i install the paper UI when all i get displayed on opening openhab on a PI3 browers shows openhab log viewer. node-red and the openhabian help dcoumentaion.

My fault skipped ui install.

Many Thanks
Peter G

you can edit /etc/openhab2/services/addons.cfg and select:

package = expert

Ref: https://www.openhab.org/docs/configuration/packages.html#expert-package-best-for-1-x-users

That worked - many thanks

Peter G

Another option is in the same file, edit this line so it contains paper

# A comma-separated list of UIs to install (e.g. "ui = basic,paper")
ui = basic,paper

Hello, I’m completely new to this, so can you pls tell me how to save and exit addons.cfg after i edit it? I can’t seem to find the right keypress for exiting :frowning:

If you would tell us the editor you are using, we could answer your question.

I position myself in “/etc/openhab2/services/” and just type “edit addons.cfg” into openhabian terminal on raspberry, and it opens in some kind of built in editor. I can’t use any high level editor at the moment because of the issue with no paperUI available.

:w write file
:q quit

Thanks !!