[solved] Missing Items on myopenhab


I have a test instance of openhab running, connected to myopenhab

If I update an value or an value is updates through its binding I see this change in the eventlog, but I don’t see the item in the “Items” view, nor can I select the item in ifttt

When I call https://my.openhab.org/rest/items the items are displayed and have the right/actual value

Is this a configuration problem in my side or a bug in myopenhab?


I’m having the same issue. Tried with sending group data as well as individual switch. My persist file is very basic.

Strategies {
default = everyChange

Items {
gMyOpenHAB* : strategy = everyChange

I looked in Habmin, and I can see the item labels,but do not see any data for the items.
Openhab version 1.8.

There was a problem with item creation in my.openHAB. Events were created but items not. It is fixed now.

Is this issue back? I’m running the 2.0 snapshot and everything was working great until almost a week ago. my.openhab says I’m online, and the url above shows all of my items, but nothing shows up in my.openhab items, so I can’t get IFTTT to work anymore.


oh looks like the my.openhab servers are having some issues…

I have the same problem now (24.11.2016) https://my.openhab.org/rest/items is updated whilst items in https://my.openhab.org/items have missing items.

Any help would be much appriciated,

My persist file looks like this
Strategies {
everyMinute : "0 * * * * ?"
everyHour : "0 0 * * * ?"
everyDay : “0 0 0 * * ?”

// if no strategy is specified for an item entry below, the default list will be used
default = everyMinute


Items {
// Persist ALL items in the persist GROUP
persist* : strategy = everyMinute, everyChange
gTemperature* : strategy = everyMinute, everyChange, restoreOnStartup
gBattery* : strategy = everyMinute, everyChange, restoreOnStartup
gAllLights* : strategy = everyMinute, everyChangw
jalla* : strategy = everyMinute, everyChange, restoreOnStartup