[SOLVED] mqtt binding 1.13 does not work anymore?

Hello, I am using openHAB in a raspberry pi with Raspbian and I had the openHAB 2.3.0 version with the mqtt binding from the version 1, but one week ago I updated the openHAB to the 2.4.0 version and I have now the mqtt binding unconfigured. I have tried to uninstall and install the binding again but I can’t send or recieve mqtt commands. In the log window It doesn’t even try to conect to mosquitto broker but I have de mqtt.cfg file in the same way.

I have read that other people have had issues due to this binding is now obsolete and there is a new one but I think that this should still work, does anybody know if this binding still works and, in the case it works, how could I configure it again?

Enable legacy bindings on the paperUI and install MQTTv1 binding
It should work again

See:

I had it enabled, in the addons.cfg file and in the Paper UI.

remove it from addons.cfg
restart oh
add it back in addons.cfg

1 Like

Thank you very much, SOLVED!