[SOLVED] MQTT binding stopped working after today's snapshot update

openhab does not seem able to send or receive anything from my MQTT, i raised the logging to debug and i have the below in my log

01:53:53.746 [ERROR] [org.apache.felix.configadmin ] - Cannot use configuration org.openhab.mqtt for [org.openhab.io.transport.mqtt.MqttService, org.osgi.service.cm.ManagedService, id=376, bundle=230/mvn:org.openhab.io/org.openhab.io.transport.mqtt/1.9.0-SNAPSHOT]: No visibility to configuration bound to mvn:org.openhab.action/org.openhab.action.mqtt/1.9.0-SNAPSHOT

any suggestions ?

UPDATE:
strange, i just uninstalled MQTT Actions and it worked, even after i re-installed the MQTT actions still working :slight_smile:
i do not know what happened :slight_smile:

7 Likes

This is interesting, and sounds similar to what people have experienced with the caldav bundles. @Kai, is this familiar to you?

I just upgraded today, and had the exact same issue, with the same solution.

Glad I found this post, I was poking around for ages wondering what had happened.

Same problem for me and same working solution.
Your post saved my day!

13:04:42.858 [ERROR] [org.apache.felix.configadmin ] - Cannot use configuration org.openhab.mqtt for [org.openhab.io.transport.mqtt.MqttService, org.osgi.service.cm.ManagedService, id=308, bundle=208/mvn:org.openhab.io/org.openhab.io.transport.mqtt/1.10.0-SNAPSHOT]: No visibility to configuration bound to mvn:org.openhab.action/org.openhab.action.mqtt/1.10.0-SNAPSHOT

13:11:20.270 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-action-mqtt’
13:11:20.294 [INFO ] [smarthome.event.ExtensionEvent ] - Extension ‘action-mqtt’ has been uninstalled.
13:11:48.969 [INFO ] [penhab.io.transport.mqtt.MqttService] - MQTT Service initialization completed.
13:11:48.978 [INFO ] [t.mqtt.internal.MqttBrokerConnection] - Starting MQTT broker connection ‘OH2MQTT’

Same problem as at TODAY!

Did an apt-update and upgrade, MQTT just stopped working completely (running mosquitto, and confirmed that manually publishing at command line things still worked, so issue had to be OH2 binding). I had made no changes to OH config whatsoever, even tried a complete reboot of OpenHAB2 - no go. After finding this post, I uninstalled MQTT 1.11 binding, got the “no visibility to configuration…” error, and still nothing would work, so uninstalled MQTT actions and bingo, everything works again. Reinstalled MQTT actions and still working.

Very odd!

Exactly the same problem for me !
I’ve lost 2 hours on this problem … :confused:

This is a very critical bug, besides losing times, that means that the MQTT messages sent that way can’t be processed in a reliable way …

So my logs are :

2017-09-25 14:08:11.392 [ERROR] [org.apache.felix.configadmin        ] - Cannot use configuration org.openhab.mqtt for [org.openhab.io.transport.mqtt.MqttService, org.osgi.service.cm.ManagedService, id=919, bundle=232/mvn:org.openhab.io/org.openhab.io.transport.mqtt/1.11.0-SNAPSHOT]: No visibility to configuration bound to mvn:org.openhab.action/org.openhab.action.mqtt/1.11.0-SNAPSHOT
2017-09-25 14:10:15.804 [INFO ] [penhab.io.transport.mqtt.MqttService] - MQTT Service initialization completed.
2017-09-25 14:10:15.805 [INFO ] [t.mqtt.internal.MqttBrokerConnection] - Starting MQTT broker connection 'mqtt-broker-jupiter'
2017-09-25 14:10:15.941 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-action-mqtt'

Events :

  • nothing was working on openhab side (whereas mosquitto worked well, same for mosquitto_sub) (restarting mosquitto didn’t helped)
  • i changed in services/mqtt.cfg the “connection id” (just in case) : i got the “cannot use configuration error”
  • i uninstalled from paper ui the “mqtt action”
  • you can see in the log that at the same time, even a few milliseconds before, the broker connection has started (at last)
1 Like

Thank you @Basem_AlSaeed . I was about to lose my mind over MQTT not working.

1 Like

Thank you!!

1 Like

Thank you! Got the same problem

1 Like

Same problem here (and same solution) after changing mqtt host IP/name in cfg. look like the problem I see with caldav. @Kai : Is there already an issue raised for this bug ?

I am not aware of any reported issue and I honestly wouldn’t even know in which issue tracker to enter it… First place would probably be openhab1-addons.

1 Like

I’m having the same problem after the update to 2.2 - same solution…

+1 :sunglasses:

For me all works fine when I removed mqtt actions (I also had to change something in mqtt.cfg to get it to connect again).
But if I install mqtt action agian, it all stops working again. Not really sure how and why, but mqtt communication works without mqtt action plugin now.
Great that there is a easy solution, but a bit unfortunate that bug builds up a fear of updating the system :smiley:

I confirm! If both are installed, binding and action, then after the update the mosquito does not work. When you delete an action, the mosquito starts to work. This happens a very long time ago.

can you try to restart the mosquito service after Openhab service is fully started and all the bindings and UI are fully loaded ?
in my case it always works after a simple restart for the service

Same issue. was starting to pull my hair out. Thanks for the solution.

This problem still exists. There is a namespace type conflict, as it is clearly referencing the action in the logs as the reason for failing.

Cannot use configuration org.openhab.mqtt for [org.openhab.io.transport..MqttService, org.osgi.service.cm.ManagedService, id=316, bundle=208/mvn:org.openhab.io/org.openhab.io.transport.mqtt/1.11.0]: No visibility to configuration bound to mvn:org.openhab.action/org.openhab.action.mqtt/1.11.0

This clearly is design/implementation flaw - see https://github.com/openhab/openhab1-addons/issues/5500#issuecomment-370210029. Both o.oh.io.transport.mqtt and o.oh.action.mqtt have a ManagedService which use the same PID (i.e. unique identifier).

i just had this happen on oh 2.2.0 release. is mqtt-action needed at this stage or can it be left uninstalled?