[SOLVED] MQTT not starting


I have a fresh installation on RPI2. I added MQTT binding in paperUI. It did not work because I did not configure mqtt.cfg.
So I followed some instruction on how to fix that. I had double entries in Karaf console, so I deleted them. Restarted openhab, and now I have NO activity in openhab.log about mqtt:

Befora I had at least
2017-09-19 21:53:20.190 [INFO ] [t.mqtt.internal.MqttBrokerConnection] - Starting MQTT broker connection ‘mymqtt’
Now there is nothing. I tried restarting, deleting default mqtt.cfg, uninstalled and installed MQTT from paperUI again… Nothing!

if you have any suggestions, please help.

Thank you!

It is unclear what exactly you have done and in what order so I recommend uninstalling the binding, removing the mqtt.cfg and /var/lib/openhab2/config/org/openhab/mqtt.config files and restarting OH. Then follow these instructions:

Problem gone!

I deleted the mqtt enrtry from the Karaf database again, and it suddenly started to display some mqtt errors in the log. Than, after a restart it connected correctly! Great! Now on to the next problem! :slightly_smiling_face: