[Solved] My.Openhab keystore certificate delete - no app functionality

Continuing the discussion from Problem: openhab 1.7 instance is shown as offline:

Hi Roher,

I believe I am having exactly the same issue as yourself, apart from my my.openhab account seems to be online and is sending information over to the website, but I cannot access it via the mobile app.

Could you please describe how you removed the certificate from the keystore and how to download the new one? The link you have put up just makes you to the my.openhab home page?

When I try to log in with the openhab app, I get the following in debug;

[DEBUG] [.r.i.resources.SitemapResource:107 ] - Received HTTP GET request at ‘sitemaps’ for media type ‘null’.
21:15:13.119 [DEBUG] [.r.i.resources.SitemapResource:228 ] - Received HTTP GET request at ‘http://192.168.1.140:8080/rest/sitemaps’.
21:15:13.515 [DEBUG] [.r.i.resources.SitemapResource:146 ] - Received HTTP GET request at ‘sitemaps/My/null’ for media type ‘null’.
21:15:13.521 [WARN ] [o.u.i.items.ItemUIRegistryImpl:471 ] - Cannot find page for id ‘null’.
21:15:13.523 [DEBUG] [.r.i.resources.SitemapResource:211 ] - Received HTTP GET request at ‘http://192.168.1.140:8080/rest/’ for the unknown page id ‘null’

Kind regards,

James

Can anyone help with this?

The myopenhab website bits are working but I cannot get the app working. I believe it to be a certificate issue as described in the above post, can anyone help me with how to do this?

Kind regards,

James

Hi! I think it’s not the same problem as mine, because my openhab instance was offline, and yours is online.
Please check the following settings in your mobile app:
openHAB Remote URL - it should be https://my.openhab.org
Ignore SSL certificate and Ignore SSL hostname should be unchecked.

Also according to the log, it seems that your app is successfully connecting, but can’t retrieve the list of sitemaps. You may validate successfull connection by selecting “Menu” -> “openHAB info”. If is shows not empty fields, than definitely the connection is successful, so the problem is not with certificates. What is displayed when you select “Menu” -> “Select default sitemap”?

Hi Victor,

Thank you for your response. I have tried the settings you speak of, however I am still unsuccessful. The remove URL is set exactly as you have it (apart from the bold type…) I have left the local blank, although I believe in my case it should be filled with http://192.168.1.140:8080

I am getting the following warnings on openhab log when I try with my iPad (multiple tries at the bottom);

2015-11-02 18:25:58.113 [WARN ] [org.eclipse.jetty.io.nio ] - javax.net.ssl .SSLException: Inbound closed before receiving peer’s close_notify: possible tru ncation attack?
2015-11-02 18:25:59.067 [WARN ] [o.u.i.items.ItemUIRegistryImpl] - Cannot find p age for id ‘null’.
2015-11-02 18:26:09.802 [WARN ] [o.u.i.items.ItemUIRegistryImpl] - Cannot find p age for id ‘null’.
2015-11-02 18:26:58.802 [WARN ] [o.u.i.items.ItemUIRegistryImpl] - Cannot find p age for id ‘null’.

Interestingly when I try from my laptop with the following link https://my.openhab.org/openhab.app?sitemap=My (adapted from the one you get when you sign into my.openhab online) I get the following error and 504 server error on the screen;

2015-11-02 18:36:06.036 [ERROR] [.myopenhab.internal.MyOHClient] - Socket.IO error: com.github.nkzawa.engineio.client.EngineIOException: xhr post error
2015-11-02 18:36:06.044 [INFO ] [.myopenhab.internal.MyOHClient] - Disconnected from my.openHAB service (UUID = 770bdbd7-xxxx-xxxx-xxxx-1026cec57662, base URL = http://localhost:8080)
2015-11-02 18:36:11.622 [INFO ] [.myopenhab.internal.MyOHClient] - Connected to my.openHAB service (UUID = 770bdbd7-xxxx-xxxx-xxxx-1026cec57662, base URL = http://localhost:8080)

I am using the app version 1.7.1 and I am getting nothing under the details for OpenHAB version, OpenHAB UUID or openHAB secret so I don’t think it is connecting properly. I do not have an option for SSL hostname, only SSL certificates, which remains unchecked. When I click select sitemap I do get the option of My Home which is the name I have given my sitemap (the file is however called My.sitemap) selecting this still makes no difference to the output.

I hope I can get this fixed as getting tablet access is key to my home automation project!

Do I need to do anything with the users.cfg file?

Kind regards,

James

Hmm, what do you have at the first line of your “My.sitemap” file?
I have the file “home.sitemap” with the following first line:

sitemap home label=“Smart Home”

So, as you can see, the name of the file and the name of the sitemap are the same.
Also try to use only lowercase letters (I don’t know if it matters, but what if yes?)

1 Like

That was it!!

I hadn’t read anywhere that the sitemap name had to be in between sitemap and label!

I had;

sitemap label=“My Home”

Now I have the following and the app connects! (I still dont have any details under the OpenHAB info section of the app though, but small victories and all!!)

sitemap My label=“My Home”

Thank you very much for your help, it really is very much appreciated!

You’re welcome, glad that I helped you :smile:

Thanks for this post, I had the same problem, but this solved the connections problem with the ios app.