[SOLVED] My.OpenHAB offline due to incorrect IP checksum

There are numerous reasons for the offline status. I have checked all hints in this community with no luck.
Then I started to use tcpdump in order to see what my Raspberry did towards my.openhab.org. And the result was quite unexpected! All IP frames had bad checksums.They will never reach their destination.

9:02:38.108376 IP (tos 0x0, ttl 64, id 54283, offset 0, flags [DF], proto TCP (6), length 60) > Flags [S], cksum 0xdce1 (incorrect -> 0x1421), seq 907395571, win 29200, options [mss 1460,sackOK,TS val 7607800 ecr 0,nop,wscale 7], length 0

I do not know where to start looking for this bug,

This is my java version:
java version "1.8.0"
Java™ SE Runtime Environment (build 1.8.0-b132)
Java HotSpot™ Client VM (build 25.0-b70, mixed mode)

This is my Linux version
Linux james 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux

Openhab was installed using apt-get.
openHAB v1.8.3.

What more can I do?
Any suggestions?

Your Java version seems to be outdated, it should at least be
java version "1.8.0_101"
Pleas update and try again.

Yes, updating java solved my problem!
Using java appears to me as a risky business.