SOLVED - My.openhab problems... some items missing and App not working

Hello guys,

I have been spend a long time setting up all my equipments inside Openhab platform…
Its all working great inside home…
But I’m facing some problems related to myopenhab that I couldn’t figure out how to solve…

The first one is that is missing just some items inside myopenhab… I dont know is there is any relation but is just missing items that are working inside rules…

the second problem is with openhab app connected out of my LAN… the sitemap do not work… if I use any browser with my myopenhab address works perfectly!!

Please guys … I know that some of you have a lot of experience with openhab and can quickly solve this issues that can help other users too.


You shouldn’t be sending all your Items to my.openhab anyway. Only those Items that you want to use with IFTTT should be configured in myopenhab.persist to be published to the my.openhab servers. You are rate limited to 20 updates to my.openhab a minute. If you have a lot of Items that are updating all the time, it is very possible that some of them never successfully get published and so never appear.

There was a bug that was causing my.openhab to publish everything regardless of what was in myopenhab.persist and I’m not sure if it has been fixed yet or not.

I don’t understand. The only way to connect to your sitemaps outside of your LAN is through my.openhab, unless you deliberately punch a hole through your firewall to allow connections from the Internet.

Hello Rich…
Thank you by your reply… Probably you right about the items… I’m sending a lot of items.
I’ll remap my myopenhab persist using just what I will use in IFTTT.

About the sitemap… just the mobile App is not working… I can use a browser to access my sitemap normally using the correct URL, login and password.
I couldnt figure out what is wrong with the APP.

Thanks Again… Regards!!!

Fit the app, set the URL to just


And remote URL to


In neither URL include the sitemap part of the URL you would use in the browser.

Use your my. openHAB user and password.

My problems were solved…

1st problem - missing items on myopenhab = Inside my items configuration I have some itens with autoupdate function set to false… so I modify to true and the items appeared on myopenhab.

2nd problem - Mobile App not showing sitemap = I was using wrong URL (, this url just work on browser.
For Mobile App the correct remote URL is


Hey Rich… Thanks a lot !!!
Some times is to simple… LOL!!!

Now my setup is working correctly… Google Home and Echo Dot controling all equipments.