[SOLVED] myopenhab.org says "Your openHAB is not online."

Unfortunately, this didn’t help me. I followed your instructions at least three times, but myopenhab.org still insists that my openHAB is not online. I changed the log level of org.openhab.io.openhabcloud to TRACE and could verify form the log entry that the cloud connector is actually using the same uuid and secret that I have entered in the myopenhab.org account.

My log says:

2019-02-01 15:12:30.324 [DEBUG] [o.openhabcloud.internal.CloudService] - openHAB Cloud connector activated
2019-02-01 15:12:30.330 [DEBUG] [o.openhabcloud.internal.CloudService] - Using secret at '/var/lib/openhab2/openhabcloud/secret' with content '(removed)'
2019-02-01 15:12:30.333 [DEBUG] [o.openhabcloud.internal.CloudService] - UUID = 4c07xxxx-xxxx-xxxx-xxxx-xxxxa1fea260, secret = (removed)
2019-02-01 15:12:30.338 [DEBUG] [o.openhabcloud.internal.CloudService] - Using secret at '/var/lib/openhab2/openhabcloud/secret' with content '(removed)'
2019-02-01 15:12:30.351 [TRACE] [io.openhabcloud.internal.CloudClient] - Manager.EVENT_TRANSPORT
2019-02-01 15:12:30.352 [DEBUG] [org.openhab.io.openhabcloud         ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.events.EventSubscriber, org.eclipse.smarthome.model.script.engine.action.ActionService}={service.id=396, mode=remote, service.bundleid=236, service.scope=bundle, expose=[localDailyForecastTodayPressure], component.name=org.openhab.openhabcloud, service.config.label=openHAB Cloud, component.id=37, baseURL=http://myopenhab.org:443, service.config.category=io, service.config.description.uri=io:openhabcloud, service.pid=org.openhab.openhabcloud} - org.openhab.io.openhabcloud

(Modified uuid and secret)

This looks good to me actually. Anything else I could try?

Trying the uninstall/reinstall approach for the nth time, I noticed this log entry:

[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-misc-openhabcloud': Error restarting bundles:
	Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.eclipse.smarthome.io.rest.sse.

However, this come after the openhab cloud connector tells me that it’s registered. What does this error message tell me?

The error entry did not occur again after restarting openHAB.

My openHAB still shows as “not online”. No idea how to track down what’s wrong.

Help, please?

Same here. Tried all the suggestions.

  1. Installed and uninstalled connector many times
  2. deleted uuid and secret many times
  3. erased and recreated myopenhab.org user many times
  4. installed and uninstalled Oracle java (cloud offline - paperUI not working anymore)

No errors in log apart from:

/var/log/openhab2/openhab.log:2019-02-06 23:42:04.760 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection

Is there anything as a DEBUG mode for the openhab cloud connector?

The log level can be set to debug, as I‘ve written above, but it doesn’t log any problems.

No one here to suggest anything?

Could you please tell me how to change the log level? I would like to check if my secret and uuid are ok

Use the karaf console to set the log level. Here’s a link to the doc’s if you have problems setting the log post your issue and we can help.

As stated above, I’ve verified that the cloud connector is using the correct uuid and secret. I assume the problem is within the cloud service, but I’m still searching for ways to tackle this problem. The logs don’t help and just leave me in the dark.

I’ve solved it!

I’ve changed the Base URL for the openHAB Cloud server configuration from the default http://myopenhab.org:443 to https://myopenhab.org – and my openHAB was immediately displayed as online on myopenhab.org.

However, after that I changed it back out of curiosity, and it continued to work. Still don’t know why it didn’t.

I’ve made a few more tests with different accounts, and it looks to me as if the order in which connector url and cloud account are configured makes the difference. The uuid and secret must be entered first in the myopenhab.org account, then the cloud connector should be installed and connected. However, if the cloud connector has been connected only once, it doesn’t work properly any more. Yet if the cloud server url is changed (in any way), then this seems to cause a reset somewhere – maybe clearing a cache or so.

So if you are sure that uuid and secret are correct, try editing the cloud server url as explained above.


I don’t know. Nothing works here!!

This is a trace

2019-02-08 02:41:31.220 [DEBUG] [o.openhabcloud.internal.CloudService] - openHAB Cloud connector deactivated
2019-02-08 02:41:31.223 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2019-02-08 02:41:31.237 [DEBUG] [o.openhabcloud.internal.CloudService] - openHAB Cloud connector activated
2019-02-08 02:41:31.240 [DEBUG] [o.openhabcloud.internal.CloudService] - Using secret at '/var/lib/openhab2/openhabcloud/secret' with content '##################'
2019-02-08 02:41:31.243 [DEBUG] [o.openhabcloud.internal.CloudService] - UUID = #######################, secret = ###################
2019-02-08 02:41:31.246 [DEBUG] [o.openhabcloud.internal.CloudService] - Using secret at '/var/lib/openhab2/openhabcloud/secret' with content '###############'
2019-02-08 02:41:31.251 [TRACE] [io.openhabcloud.internal.CloudClient] - Manager.EVENT_TRANSPORT
2019-02-08 02:41:31.254 [TRACE] [io.openhabcloud.internal.CloudClient] - Transport.EVENT_REQUEST_HEADERS
2019-02-08 02:41:31.256 [DEBUG] [org.openhab.io.openhabcloud         ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.events.EventSubscriber, org.eclipse.smarthome.model.script.engine.action.ActionService}={service.id=378, mode=remote, service.bundleid=235, service.scope=bundle, expose=[openwebnet_bus_on_off_switch_MYHOMESERVER1_000350a469c9_02_switch], component.name=org.openhab.openhabcloud, service.config.label=openHAB Cloud, component.id=225, baseURL=https://myhopenhab.org/, service.config.category=io, service.config.description.uri=io:openhabcloud, service.pid=org.openhab.openhabcloud} - org.openhab.io.openhabcloud
2019-02-08 02:41:31.876 [TRACE] [io.openhabcloud.internal.CloudClient] - Manager.EVENT_TRANSPORT
2019-02-08 02:41:31.879 [TRACE] [io.openhabcloud.internal.CloudClient] - Transport.EVENT_REQUEST_HEADERS

Should I restart the whole chain uninstall-install-configure once more?

What you exactly mean with " if the cloud connector has been connected only once, it doesn’t work properly any more"?

I mean the binding obviously does not disconnect and reconnect with a new uuid and secret, unless you uninstall and reinstall it or you change the url. However, changing the url seems to work more reliably which makes me think that there is some sort of internal cache that doesn’t get cleared otherwise.

Have you verified that uuid and secret are identical and did you change the url as explained above?

Only after I had changed the url, I saw this message in the log:

[INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = xxxxxxxx-4bec-4805-a8e0-xxxxxxxx, base URL = http://localhost:8080)

This message wasn’t logged before when it did not work, so the problem probably was that the cloud connector did not really connect to the cloud, but I don’t know why. Do you see this message in your log?

After setting a high log level in the console:
log:set DEBUG io.openhabcloud.internal.CloudClient
I saw this warning in the log:
2019-02-21 14:59:41.151 [WARN ] [o.openhabcloud.internal.CloudService] - You are running Java 1.8.0_65 - the openhab Cloud connection requires at least Java 1.8.0_101, if your cloud server uses Let's Encrypt certificates!

Fixed that as follows:

  1. Using Paper UI, put a garbage base URL in the settings for the IO Service Open Cloud.
  2. Stopped openhab2, using systemctl stop openhab2
  3. Updated java to version “1.8.0_201” (Google updating java on raspbian, because the recipe depends on what version of debian your raspbian OS is based on. xenial in my case.) I used these instructions.
  4. restarted openhab2 using systemctl start openhab2

The log showed:
[INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = 161dca61-73b0-46c5-8874-bdd11d47faf2, base URL = http://localhost:8080)
because of the bad base URL.

  1. Back in Paper UI I set it to the proper https://myopenhab.org and it immediately reported that it was online.

Now to carry on with Alexa.

1 Like

Kind of a mystery. After one hundred attempts, now it went online. You pointed me to the right direction, though, even if in my case it was not a java problem. I had Zulu 1.8.0_152 and it was not working. I installed Oracle to no avail, then back to Zulu and now is working with it.

It turned out that reinstalling and reconnecting the cloud connector after changing the url as suggested by @metin was not enough. A reboot was not enough either.

What did the trick for me was setting the url to some ppp.org, then stopping and restarting openhab2 via systemctl, then changing again the url to myopenhab.org, stopping and restarting openhab2. Add a reboot at some time as an extra.

Thanks to the both of you and to the right planet alignment.

1 Like

For me, the fix was changing the URL from https://www.myopenhab.org to https://myopenhab.org (removing the www).

Thanks Dave_Thomas, changing from “myopenhab.org” to “https://myopenhab.org” worked for me.

Thanks for the tip how to connect myopenhab, solved the problem:rofl::innocent::nerd_face:

By Dule

Release = Raspbian GNU/Linux 9 (stretch)
Kernel = Linux 4.9.80-v7+
Platform = Raspberry Pi 2 Model B Rev 1.1

Adding “https://” in openHAB cloud configure to base url solved my problem.

I had the same problem with this as many others.

To solve it I changed the settings in the openHAB cloud connector from https://myopenhab.org/ to just https://myopenhab.org. Suddenly it connected. Unsure why changing this worked. Maybe it needed the setting changed to refresh the connection.

I now see a messaging saying " You are using openHAB 2.x. [Click here to access your openHAB’s dashboard]" on the website.

On a side note, I had all sorts of trouble getting my openHAB on a secure URL (with SSL on a synology diskstation). I’ll details more about that in another post later. Had to enable port forwarding and a virtual host on my web station.


I had the same problem. I removed the last “/” as well and it connected to the cloud.
BUT - I still can’t see any Items in the cloud.

works for me OK. thanks

Thanks, I had tried all of the above solutions to no avail - changed the base URL and it worked IMMEDIATELY

Thanks for the research