[SOLVED] MyopenHAB remote control (dashboard) fails with active VPN connection

Platform information:
Hardware: RPi 3 B+
OS: openHABianPi 4.14.98-v7+ #1200

Hey I want to setup one OH installation for two (not direktly connected) networks. See simple schematic. I want to control everything with HomeKit (no ATV, HomePod, iPad as bridge) and webui.
I mainly use MQTT for my sensors, and switches.
So I connected (vpnc) my RPI to my VPN server located in the other network.

When my vpnc script connects my RPI to my Home 2 myopenhab remote control connot access anymore (timeout). (Notifications are still working).

SSH, web access and MQTT on the vpn side is also not stable/ or not available.

I tested allready

  • ping vpn router (works)
  • ping local router (works)
  • Internet acess (works)
  • myopenhab (shows online)
  • no related errors in logfiles
  • connection speed stable but just 1 Mbps
  • disconnected vpnc -> myopenhab showes offline -> after 10 min online again with remote access

simple schematic

Is this even possible? Why is myOH stop working?
thanks for helping

This is probably going to be more likely to get the help you need posted to a vpnc forum. If SSH and MQTT are not stable then the problem is outside of OH. And while a minority of users on this forum use VPNs, only a tiny minority use vpnc.

Thanks for your answer :slight_smile:
As I understand: vpnc is just the client for the vpn connection.
The VPN connection seems to work

This was maybe a config problem with mqtt.fx. With this app it works.

So back to the myOpenhab connection problem. Any ideas on this issue?

2019-04-09 22:04:17.380 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = xxxxxxxx, base URL = http://localhost:8080)
2019-04-09 22:04:19.340 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = xxxxxxxx, base URL = http://localhost:8080)
2019-04-09 22:07:45.040 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: {}
io.socket.engineio.client.EngineIOException: xhr poll error
	at io.socket.engineio.client.Transport.onError(Transport.java:71) [210:org.openhab.io.openhabcloud:2.4.0]
	at io.socket.engineio.client.transports.PollingXHR.access$100(PollingXHR.java:19) [210:org.openhab.io.openhabcloud:2.4.0]
	at io.socket.engineio.client.transports.PollingXHR$6$1.run(PollingXHR.java:124) [210:org.openhab.io.openhabcloud:2.4.0]
	at io.socket.thread.EventThread$2.run(EventThread.java:80) [210:org.openhab.io.openhabcloud:2.4.0]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]
Caused by: java.io.IOException: 400
	at io.socket.engineio.client.transports.PollingXHR$Request$1.run(PollingXHR.java:218) ~[?:?]
	... 1 more


just for the record:
The problem was a wrong vpnc default mtu.

After setting it (–ifmtu vpnc man page)
from 1412 to 1380 every thing works as aspected.