[SOLVED] Myopenhab reports Your openHAB is not online

After a reinstall (I downgraded from 2.5 M5 to 2.4 with a fresh install) MyOpenHAB reports that my server is offline. I have used it with version 2.5 M5 successfully, but I am not able to connect to myopenhab with my newly installed version 2.4.0-1.

I followed the drill of stopping the service, uninstalling openhab cloud connector, removing uuid (with and without the openhab secret directory) cleaning the cache, restarting the service, reinstalling the connector and entering the new uuid and secret in the account. After several attempts I deleted and recreated my myopenhab account, but no success.

I am running Openhabian on a Raspberry Pi 4B 4Gb with:

  • RFXCOM transceiver + binding
  • Razberry Z-Wave controller + binding
  • other bindings: Hue, Astro, Evohome
  • Pushover service

All works fine, even great on my local network.

Any tips? Or is it the MongoDB issue again?

Thanks in advance!

Did you update myopenhab with the UUID & secret for the new installation?

Yes, I did a fresh install of Openhabian and afterwards several attemps of uninstalling and installing the Openhab Service. Each time I deleted the UUID file and also in some attempts the openhabcloud directory including the secret.
Each time after installing the Openhab cloud connector I changed the UUID and secret in myopenhab account setting.
My last attempt included deleting my account and register as a new user. I then had to enter the uuid and secret in the registration process.
I just checked myopenhab: my openhab is still offline from a cloud point of view.

I had a similar issue when upgrading OH. Anything in the logs that mentions an error about the cloud service? If so have a look at what was need to fix the issue for my situation here.[SOLVED] No opencloud when upgrading from 2.4 to 2.5M4

1 Like

Nor in the openhab-log or the event-log are any error messages. But with the stable version coming soon (this weekend?), I will give it try with 2.5 Stable and see if that changes anything.
Thanks for your tip!

Alas, a fresh install with OH2.5 Openhabian did not solve my problem with MyOpenHAB: still no succes to connect. SInce I had it running with 2.4 I know it could work. So my questions:

  • are there specific logs or log-messages that I need to analyse?
  • are there perhaps security / firewall settings the I need to check?

I moved from a mixed OpenHAB/HomeKit environment to OpenHAB-only because with the openhab cloud and the 2.5 bindings for iCloud there was no need to use both platforms. So I hope I can get this working! Any help or hints are appreciated!

PS I did copy the new UUID and secret after the fresh install to the MyOpenHab account settings.

Use frontail log and you can open a browser and see the logs. To install frontail do so with the openhabian tool. Not sure the exact option to select but I think it’s in same place where you install mqtt broker.

EDIT: Its under “Optional Components” then select number 21 for the frontail log. After you have it installed just go to the main OH start page in browser and you should see the log view.

Hi H102,

Thanks for your reply. Since I could not find a clear message in the OpenHab and event log, I wondered if there were any other (system) logs that could give hints to the cause of the problem. I will scrutinize the OpenHab logs again.

After digging into the logs I found a clue: an error message about not being authorized to connect to myopenhab. The good news was that there was communication between my server and the OpenHab-cloud. However, I could not figure out why authorization failed. After a lot of attempts of un- and re-installing the OpenHab cloud connector, re-entering the uuid and secret, creating new accounts with different email-addresses the following steps did solve the problem.

  1. uninstall the OpenHab cloud connector (OCC) binding and deleting the uuid file and secret file in the user data directory.
  2. restart openhab without the OCC binding.
  3. install the OCC-binding. New uuid and secret files are generated.
  4. copy uuid and secret in the MyopenHab account.
  5. restart Openhab

So after the restarts between the steps the problem was solved. I now can take the next steps in my OpenHAB education, using the OH UI’s and tools to control all components of my home automation setup and create the rules and flexibility that I seek.