[SOLVED] Neo CoolCAM PIR Sensor Z-Wave Issues

@chris, @sihui. @5iver

  • Platform information:
    • Raspberry Pi 3B+
    • Raspbian Lite 8 (Stretch)
    • sudo java -version
      openjdk version “1.8.0_212”
      OpenJDK Runtime Environment (Zulu8.38.0.163-CA-linux_aarch32hf) (build 1.8.0_212-b163)
      OpenJDK Client VM (Zulu8.38.0.163-CA-linux_aarch32hf) (build 25.212-b163, mixed mode, Evaluation)
    • openHAB version: 2.5M2

I now have 2 NeoCam PIR sensors with a different ID than my previous one. I initially got them in OH and identified. When I started trying to use one of them, I suspected the Thing may not have been fully initializes, so I removed the Thing and rediscovered.it onluyshows ad “Unknown Device” with no IDs.
I notice neither sensors have xml files produced. Here is the info from one of them when first discovered.
image image

How do we want to troubleshoot this?

I suspect that it’s only partly completed the initialisation. There are type/id’s defined, so it knows the manufacturer data, but firmware version is 0, so that is the missing bit of information required to determine the thing type.

My guess is that it needs to be woken up to finish discovery, but if you’ve done that a few times and it’s not getting there, then please provide a debug log and I’ll take a look.

So, delete the thing, turn on Debug logs, & rediscover?
i suspect the one that is recognized is only partial.
I think I will try exclude, reset, & include again on the Unknown device first.

For starters, just try waking it up - however that is done on this device. If that doesn’t work, stop the binding, delete the XML, enable debug, and restart the binding. Then wait a minute or so for things to calm down, then wake up the device a bunch of times - say once every 5 seconds for 30 seconds or so. Then send the debug log…

OK, but no XML to delete and I have already tried that.
I now have it excluded & reset. My next step is to turn on Debug logging, and then include/discover. I had this fail with no debug logging so perhaps we can figure this our with logs.

@chris With debug logs on it is recognized but still no XML.
IIRC the xml file indicates the device has been fully discovered, correct?

EDIT: I accidentally reset the log to INFO not DEBUG

The XML file is written at different times - first once an initial discovery is complete and the binding knows the thing type, then again once the discovery is complete, then it may be written at other times to save updated information.

Is there any way to tell it to save?

No - it’s automatic.

1 Like

I just noticed this. It is reporting luminance (which I do not use.Logs with search for NODE 11

2019-08-18 10:24:38.254 [DEBUG] [tocol.commandclass.ZWaveCommandClass] - NODE 11: Received COMMAND_CLASS_SENSOR_MULTILEVEL V0 SENSOR_MULTILEVEL_REPORT
2019-08-18 10:24:38.257 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 11: Sensor Type = Luminance(3), Scale = 1
2019-08-18 10:24:38.260 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 11: Sensor Value = 256
2019-08-18 10:24:38.264 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 11: Got an event from Z-Wave network: ZWaveMultiLevelSensorValueEvent
2019-08-18 10:24:38.268 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 11: Got a value event from Z-Wave network, endpoint=0, command class=COMMAND_CLASS_SENSOR_MULTILEVEL, value=256
2019-08-18 10:24:38.271 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 11: Updating channel state zwave:device:16b83f77166:node11:sensor_luminance to 256 % [QuantityType]
2019-08-18 10:24:38.274 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 11: Commands processed 1.
2019-08-18 10:24:38.276 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 11: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@176fae1.
2019-08-18 10:38:45.661 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 11: Polling...
2019-08-18 10:38:45.665 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 11: Polling deferred until initialisation complete

It is getting data but initialisation never completes

I’d need to see the debug log to know what was happening…

Here are the zipped up logs. Change the file extension as needed :wink:

events.zip.txt (467.4 KB)

The device I have been working with started as node 8 then 10 and now 11.
Node 9 is the same model that has now been reconnected. It has been woken up but I think it is incomplete too.
Node 3 is my older sensor but the same model / database entry.

This is the events log - not the debug log. This just shows the events when things changed, not all the “thinking” that the binding is doing.

OK I need to capture the debug log to a file then.
I thought since the debug showed up in Frontail it was in the events log/

Bruce, I´m using a Type / ID 0003:1083 Neo coolcam pir.
What i discovered with this devices is, that you have to keep on pushing the button to wake up the device (or keep it awake) during the inclusion… It kinds odd, cause my other z-waves devices dont react the time…
I think I had to push it 3-4 times last time I did the inclusion. If I dont, the inclusion will end ind a Unknow Device situation.

Indeed, I’ll agree with Kim here and say my experiences with a number of different brands of battery powered devices is that some of them need woken a whole bunch of times. To me a few times it really seemed like it was not working and something was wrong. In the end, it took a bunch of tries
I do it like this, I sit in front of Paper UI, I trigger discovery, I hit the wake button, if the search ends with out success I restart discovery and hit the button again I repeat this process until it works

I remember that with my 0003:108d.
These 2 new ones will NOT complete though, no matter how many times I press the button.
This last time I made sure I was right next to the USB stick.
I plan on
reset the sensor,
stop zwave binding,
set DEBUG,
start zwave binding,
Parse logs / post here for Chris.

OK, IT looks like I got closer & actually have an xml file too.

xml file: network_eb1f63a9__node_13.xml.txt (15.6 KB)

debug logs (zipped) zwave.zip.txt (129.7 KB)
EDIT: Looking closer, I suspect luminance & motion may be working but not temperature. I am primarily interested in motion anyway with temperature as a secondary interest.

Bruce, it sometimes takes a little while for temperature to be reported, especially with battery devices that try to conserve ‘air time’ (actually broadcasting) because it uses the most battery power.

If you got luminance and motion, you got it man

1 Like

I noticed some UNDEF reports in the log viewer. I wondered if they were temperature. My other sensor reports temperature very regularly.
Now I need to get Zooz to replace my first try with their switch. They have good ideas but apparently poor quality control in their manual switches, I think.