[SOLVED] NEO Wallplug (NAS-WR01ZE) is in the database but is shown as Unknown Device

I use openHAB 2.4 stable with an AeoTec Z-Stick Gen 5 and a Neo Wallplug (NAS-WR01ZE). The Z-Wave sticks works fine, but after I added the wallplug it is only shown as Unknown Device

Z-Wave Node 002 (0258**:0200:1027**:2.32), Unknown Device

I looked at the Datebase and the Wallplug is listed:

Manufacturer Shenzhen Neo Electronics Co., Ltd
Manufacturer ID 0258
Name NAS-WR01ZE
Device Description Wall Plug Switch
Category Power Outlet
References (Type:Id) 0100:1027,0200:1027
Firmware Versions Version 2.32
Protocol Version 6.002
Library Type LIB_SLAVE_ENHANCED

I have reset my Z-Stick and the Wallplug too and installed both again but the plug is still shown as unknow.

What can I do to install it properly?

Thanks
Michael

You need to upgrade your zwave binding to 2.5 snapshot to pick up the database changes regarding firmware version 2.32 of your device.

1 Like

Thanks, now it works

1 Like

Hello I got the same problem, but my firmware version is 2.21
I have 2.5M3 installed and cant get the plug working.


Any hints ?

I’ve updated the database to resolve this.

Hi, Chris. Sorry for disturbing youm but I also have a problem with this device. It’s detected by binding, channels are detected as well, but configuration isn’t available. I use Openhab 2.5.0 release from last weekend with all updated bindings, device was bought and first time included today.
I attached screenshots with device information and configuration page.
Also, i tried next: remove thing and add it once more, clean the cache - problem still is present.

Delete the Thing and readd it.

This helped me with another device, door/window sensor, which i added a long time ago, but not with this new plug.
As I wrote in my post, I removed and added the thing without any result. I also removed device from network and included it again without security and like new nodeId - also no configuration. BTW, I noticed that device manual also didn’t appeared on page.

The one more problem with this device is present.
Please, see attached screen - Electric_KWH is reported twice, once with -2… value, and once with voltage value. It’s really strange.

Ok, i found the problem - my device is recognized for dbReference 1117 which is marked as deleted…
But the question is - why it uses that device and how change this?
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1117

Update to the latest zwave snapshot binding and delete the Thing and readd it.

Do you still have a zwave binding manually installed through your addons folder?

Please check via Karaf and

bundle:list|grep -i zwave*

Do you still have a zwave binding manually installed through your addons folder?

I installed z-wave binding through paperUI, it was updated to 2.5.0 together with openhab.

bundle:list|grep -i zwave*

276 │ Active │ 80 │ 2.5.0 │ openHAB Add-ons :: Bundles :: ZWave Binding

Will try now to update to latest snapshot version

What was done:

  • Updated version ZWave binding using script. It became next:

286 │ Active │ 80 │ 3.0.0.201912190353 │ openHAB Add-ons :: Bundles :: ZWave Binding

  • Removed Thing from openhab
  • Removed it’s xml file from /var/lib/openhab2/zwave/
  • Restarted openhab
  • Added device again through inbox in paperUI

dbReference is still 1117, pointing to deleted device in database.

BTW, the release version of zwave binding had place 4 days ago - i don’t see any changes since that time, which can result in this issue. From my point of view, the possible solution will be to somehow corrupt this device in database (f.e., set non-existing manufacture, device id etc…).
And, one more, binding shows me 4 such devices, while in device database only 2 are active.

Could you please post your xml file for that node?

Sure. Here it is. node6.xml (9.7 KB)

Your type and id definitely points to a valid database entry:
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1014
The only explanation I have that some old config is cached on your installation.
Please clear the cache, then again delete the Thing and readd it.

Still the same :frowning: Cache was cleaned using openhab-cli, then i manually checked the content of /var/lib/openhab/ - no cache or tmp directories exists, directory .cache also was empty.

Started openhab2 again, removed added device and again that 1117 without config.

2019-12-19 17:03:59.515 [hingStatusInfoChangedEvent] - ‘zwave:device:7e178d6a:node6’ changed from ONLINE: Node initialising: REQUEST_NIF to ONLINE
2019-12-19 17:04:28.716 [hingStatusInfoChangedEvent] - ‘zwave:device:7e178d6a:node6’ changed from ONLINE to REMOVING
2019-12-19 17:04:28.732 [hingStatusInfoChangedEvent] - ‘zwave:device:7e178d6a:node6’ changed from REMOVING to REMOVED
2019-12-19 17:04:28.758 [hingStatusInfoChangedEvent] - ‘zwave:device:7e178d6a:node6’ changed from REMOVED to UNINITIALIZED
2019-12-19 17:04:28.924 [hingStatusInfoChangedEvent] - ‘zwave:device:7e178d6a:node6’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2019-12-19 17:04:54.720 [ERROR] [ntime.internal.engine.RuleEngineImpl] - Rule ‘co2_notification’: Could not cast NULL to java.lang.Number; line 23, column 44, length 32
2019-12-19 17:05:01.905 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:7e178d6a:node6’ to inbox.
==> /var/log/openhab2/events.log <==
2019-12-19 17:05:01.908 [home.event.InboxAddedEvent] - Discovery Result with UID ‘zwave:device:7e178d6a:node6’ has been added.
2019-12-19 17:05:08.184 [me.event.InboxRemovedEvent] - Discovery Result with UID ‘zwave:device:7e178d6a:node6’ has been removed.
2019-12-19 17:05:08.208 [hingStatusInfoChangedEvent] - ‘zwave:device:7e178d6a:node6’ changed from UNINITIALIZED to INITIALIZING
2019-12-19 17:05:08.241 [hingStatusInfoChangedEvent] - ‘zwave:device:7e178d6a:node6’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
2019-12-19 17:05:08.243 [hingStatusInfoChangedEvent] - ‘zwave:device:7e178d6a:node6’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE
2019-12-19 17:05:08.251 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:7e178d6a:node6’ has been updated.
2019-12-19 17:05:08.309 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:7e178d6a:node6’ has been updated.
2019-12-19 17:05:08.320 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:7e178d6a:node6’ has been updated.
2019-12-19 17:05:08.327 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:7e178d6a:node6’ has been updated.
2019-12-19 17:05:08.346 [vent.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]

Then I am out of ideas and we need to ping @chris

No problem. Sorry for disturb. Let’s wait for Chris.