[SOLVED] NEO Wallplug (NAS-WR01ZE) is in the database but is shown as Unknown Device

I checked also the github repo for z-wave binding and found, that this device with id 1117, which is marked as deleted, is present in repo, was added 3 months ago to master branch.

I’ll need to do a complete database update to purge the current device from the system. When a device is deleted in the database, the github repo doesn’t get updated to remove it there, so I need to delete and generate the complete database.

I will try and do that this weekend if I can - if there’s not too many problems I’ll publish it, but if there are many issues, it may need to wait until Christmas as I’m away for a couple of days from Sunday.

2 Likes

Super. Thank you a lot! :slight_smile:

@chris Hello. Sorry for disturbing you in Christmas. :slight_smile: Do you have any news about DB update and device remove?

I’ll trigger that now.

@sihui FYI this will probably update most devices as the database now uses a different XML reference (removing the ESH references). This was changed a month or so back, but after the last full export. That will make it hard to see changes as we’ll have near on 2000 updated files :roll_eyes:.

Thx, no problem.
I’m expecting a lot of changes for all the zwave christmas presents. :grinning:

2 Likes

@chris @sihui - thank you a lot! :slight_smile:
I installed version:

297 │ Active │ 80 │ 2.5.1.201912260340 │ org.openhab.binding.zwave

And now switch configuration is available, item is discovered with dbReference 1014

2 Likes

Hello, I have same CoolCAM Power Plug and same issue with 2.5.0 Z-Wave binding. Where can i get newer version?

https://ci.openhab.org/view/Integration%20Builds%20(2.5.x)/job/openHAB2.5.x-ZWave/

Thank You! Can You share some tips how to update existing binding? I’m little confused with this. I’ve tried use script but it doenst work on my RPI. I’ve tried to login to openhab console and do binding:update URL but it didnt work.

Script didn’t worked for me too.

I did next steps and, at least, it works for me now. Before executing them, please, read all of them and make sure, that you understand each of it and you know how to execute it.

  1. Download all needed jar files ( org.openhab.binding.zwave-2.5.1-SNAPSHOT.jar) and (xstream)
  2. Login to karaf console in raspberry (you should be already logged in to your RaspberryPi, ther execute the command ssh openhab@localhost -p 8101, password habopen)
  3. Remove zwave bundle using next command bundle:uninstall org.openhab.binding.zwave
  4. Go to paperUI and Uninstall Z-wave binding if it’s shown as installed (Addons -> Bindings -> Z-wave 2.5.0).
  5. Logout from karaf and copy both jar files to directory /usr/share/openhab2/addons
  6. Login back to karaf and install transport-serial feature:install openhab-transport-serial
  7. Check list of installed z-wave bundles list -s | grep zwave - there should be only one zwave binding with new version
  8. Remove your thing (Neo plug) and add it again in paperUi - then it should work. If no, restart OH2 and clean the cache (openhab-cli stop, openhab-cli clean-cache, openhab-cli start). Also, it’s recommended to remove (not exclude from network!) and add all things, except the controller, which are z-wave devices. In my case this was not needed.
2 Likes

Majestry, thank you very much! Your step by step instrukction was very clear and it worked!

You’re welcome.