[SOLVED] Nest Setpoint Not working

Hello every body,

it’s my first post here I hope find help.
I install the binding Nest and all work fine I can change mode et get info, but I can’t set a setpoint temperature.
In log I find :[WARN ] [nding.nest.handler.NestBridgeHandler] - Nest API error: blocked

I delete all and try again but the same error.

My sitemaps code

Frame label=“Nest Thermostat”
Text item=Nest_humidity
Switch item=NestHome_Mode icon=“present” mappings=[HOME=“HOME”, AWAY=“AWAY”]
//Switch item=NestThermo_Mode icon=“present” mappings=[HEAT=“HEAT”, ECO=“ECO”, OFF=“OFF”]
Setpoint item=Nest_SP

and my items code

Number:Temperature Nest_SP “Set Point [%.1f]” { channel=“nest:thermostat:01675014ksdsfakecodetoken:set_point” }

Where I make the mistake ?
I try to change from Domoticz to OpenHab more WAF.
All install in RPI 3B OpenHabian

Thx all


The API said ‘blocked’ my guess is you sent too many commands to Nest at the same time and they temp blocked you from using the API; give it an hour or two and you should be auto unblocked.

1 Like

but I can change the mode and getting again information from Nest.
Nest/Google can just block the setpoint ?


If you can set other aspects via the API from openhab, then you possibly have something misconfigured with the set point?

I think its a full block vs individual API call blocks, but I’m not sure I have my temps fully automated via rules and don’t have to mess with the set points, other then updating a global var in my rule.

I’m try to switch from Domoticz to Openhab2.

In my Domoticz I use only the connection with Event(Rules in Openhab).
Like this : commandArray[‘OpenURL’]=“

I don’t have again see how work rules in Openhab but if you say me it’s possible to set temp without this item I’m very interrested.


@ [anonymous.one]

You were right it’s now in order.
I’m just block by Google API.

Thx :grinning:

An item is still required for rules to work, I don’t have a sitemap or habpanel widget to control the temp. :wink: