[SOLVED] New NEO Coolcam ZWAVE Roller Shutter Identification Problems

Tags: #<Tag:0x00007fc1f6dc90a0>

Hi guys, glad to greet you, I’ve been reading this community for a long time and learned something new every day.

I am writing to see if you can help me in any way.

I have been working without problems on my OPENHAB for some time with some ZWAVE cheap NEO Coolcam devices that can be found in Chinese online stores. (powerswich, push buttons, door sensors …)

Recently I bought a new device called “NEO Coolcam Roller Shutter ZWAVE” that can be purchased for less than $ 30.

The problem is that once paired in my OPENHAB 2.5.0.M1 it does not recognize the channels and I cannot interact with it.

I pass all the information I have of it, in case anyone can help me. Thank you.
-DEVICE: https://www.aliexpress.com/item/33040254263.html?spm=a2g0s.9042311.0.0.1f414c4dOE8hMU

TKS

Hi,
Welcome on board…

The device doesn’t appear to be in the database, so will need to be added. Please see the link below for information and if you have any problems/questions etc, please ask here and we’ll be able to help.

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide

1 Like

Hi Chris, thank you very much for your welcome and for your help. I haven’t been able to answer you before, my account stayed on hold.

I have followed your instructions, and I have registered the device:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1108

, but I am new, and I am not sure how to register the parameters and commands.
I have attached the manual in pdf.

Could some advanced user help me finish configuring this device to use it?
Thank you very much for your help.:+1:

Hopefully I can look at it shortly unless somebody else beats me to it.

EDIT:
LOL That is what I was working on! Just completed for review. I kept most of the very broken English from the manual rather than try to clarify the parameters.

Feel free to update with easier to understand information.

2 Likes

Thanks Bruce for your help.
You know how these cheap Chinese products are, it is necessary to decipher the manuals to understand something.
What is the procedure to test my unit and verify that it is correctly parameterized?
Greetings. Goodnight!!

After you get the new binding installed, just delete the Thing from OH and rediscover. You should then see the configuration parameters & channels, as well as being identified correctly.

I actually have some coolcam PIR sensors I bought from aliexpress. n fact I am trying to get a warranty claim on one because it partially hangs during a network heal. The Coolcam people say I need to get it replaced by my vendor, so I am messaging China through Aliexpress.

Thanks Bruce.
Is true, the cheap chainise stuff is a lotery. Sometimes work and you win, other you lose.

I’ve been trying to make this device work, I have not achieved.
The steps I have taken are as follows:

1-I deleted the device and created it again -> Without success
2-I have removed the zwave biding and installed it again, and I have repeated step 1->Without success
3-I have updated from 2.5.0.M1 to version 2.5.0.M3 and repeated step 2 -> Without success

Any idea what I’m missing?

Weird.
That indicates manufacturer 0600 which appears to be unassigned. The Neo Coolcam products are normally id 0258
@chris how could you explain this? Somebody just grabbed the ID?

In PaperUI this number gets printed in decimal - Decimal 600 is hexadecimal 0258 so that is correct.

1 Like

For Z-Wave that is incorrect and almost useless though. I suppose any attempt to change that has been abandoned.

What do you mean? It’s 100% correct.

Change what exactly? Sorry - I’m just not sure what your issue is?

1 Like

Z-Wave uses hexadecimal format. PaperUI development is no longer occurring. You likely do these conversions in your sleep, unlike the majority of users trying to solve their problems.

If the OH3 anointed admin interface converts similarly, it might be worthwhile to change the database device & manufacturer listings appropriately.

:confounded: - ZWave often prints data in hex, yes, but a number is a number, and it’s still exactly the same value if you print it in decimal, hexadecimal, binary, octal etc.

This is stored as a number - most systems print numbers as decimal.

Not at all - I use a calculator.

Please remember that PaperUI has no real knowledge of bindings - it just prints these properties as it sees them. It doesn’t have any way to know how to format data. There is no conversion - it’s just printing the number.

The database just prints numbers - sometimes it’s in hex, sometimes it’s in decimal. Behind the hood is a database that is storing numbers. It’s been like this for 4 years and I don’t really see that it’s a problem.

1 Like

Thanks Bruce & Chris for your help.
So, what i’m doing wrong?

It was last updated 2 days ago so the latest changes have not been exported to the current snapshot binding.

I think it will have been exported. I did an update on Sunday night which is included in the binding now. I’m not 100% sure about this device, but in general I’ve been avoiding approving any further changes since then.

2 Likes

Hello again.
I let some time pass before I tried again. But it continues without being recognized.

I use a raspberry and I’m in the Milestone 2.5.0.M3.
1- I have deleted the things
2- I have removed the Zwave binding
3- I added the Zwave binding
4- I have searched for new things and the blind switch has appeared, but it remains unidentified.


What may be failing?

Lot´s of thanks

That device in the database was last updated 18 days ago which is much after 2.5M3 was released.
You need to upgrade your zwave binding to the latest snapshot, delete the Thing from OH, and rediscover it.

1 Like

Yeeesss!!! Working!!!:champagne:
Indeed, I needed to upgrade from version to snapshot.
Thank you very much for your help. Without it, it would have been impossible.:star_struck:

image

Glad to see that you finally could make it working.
I bought exactly the same device for all my blinds. I’m confident of not getting into major troubles to add the devices to my hardware (I’ll use domoticz, in principle).
I want to ask is someone experienced problems with the calibration of the switch.
Once installed, I follow the instructions and calibrate upward and downward times.
But for some reason, a couple of switches “loses” the calibration after 1-2 days, and stopped before reaching the end
Would you give me some advice, please?