[SOLVED] New Rules Engine

This is fixed in the snapshots, along with a few other issues. If you disable all of your rules and restart OH, it may resolve the issue for you.

Thanks, 5iver. I need to bite the bullet and move to 2.5. I was on the 2.4 snapshots when I was first setting everything up and just continued with stable once it was released. I suspect I’ll have to set all my zwave stuff back up again if I move to snapshots. I may do it this weekend, but I have to be sure nothing is broken as I travel most weeks and my wife will beat me soundly if I leave stuff in a non-working state.

I’m assuming when you suggest disabling all the rules and restarting OH, that is on the snapshot version…or do you think that might also work with 2.4 stable? Was the fix back-ported?

Thanks again.

There are no breaking changes for zwave like there were in 2.4, so it should just work.

The fix was not back ported to 2.4. In my troubleshooting of the issue, I found that UI created rules would start properly if they had all been disabled and OH restarted. It’s a one time effort too, meaning you don’t have to do this before every restart. I believe I confirmed this on 2.4, since another user was reporting it on that version, but I could be mistaken… I might have only tested it on 2.5M1 and 2.5 snapshots. Here’s the GH issue…

If your environment needs to be stable, I do not recommend a snapshot build at this time. In particular, there was a fix for zwave healing recently that is causing some trouble and will require you to disable the nightly heal or everything zwave stops responding. At least, that’s what is happening here. There are also still open issues with hueemulation and MQTT2.

Just to be clear, I’ve been having this issue with heal for quite a while. So has @digitaldan. We’ve just been reporting different symptoms of the problem. From my perspective, this PR doesn’t make things any better or any worse.

OK, got it. Thanks all. I’ll try the disable/restart/re-enable and see if that takes care of it on the most recent 2.4 stable drop. I’ll report back on this thread.

Yep, that seems to have worked. I’ll just have to remember to do this each time I add/change a rule. Thanks!

Sweet! As I had said, the rules should behave normally now… no need to repeat the process.

1 Like

Agree, as home automation becomes more popular, more software platforms are getting created. If Openhab wants to be in the most used list we need to keep changing or be left behind and this affects the number of developers working on Openhab.

In this video Mozilla Webthings is shown how they handle rules at 8:45

1 Like

What I’ve learned is that the OH userbase is very much text driven, as well as a lot of the OH core maintainers.


That’s right! And I love these very good features that set openHAB apart from other systems. This results in a flexibility that nothing else can offer me even close to.

But it’s not about replacing one with the other. But openHAB needs both abilities in the future.

The graphic side is quite improvable but I see very good progress at present. There has been a lack of people to take care of these issues. Some new developers and also with your help the programming of the graphical editing is progressing better, I have the impression.

Anyone who know why I have muliple entries of things to select from?
They are obviously exactly the same.

And when I delete one using karaf, I will have another one added.

How to get rid of these?

If they are identical, then how can you delete just one? :slight_smile: What do you see in Paper UI> Configuration>Things?

This Action is from a binding, so you may need to look into the binding code or ask it’s maintainer.

Thanks for your help.

If I delete it in Karaf, all three are still shown in the rule engine.
In Paper UI Things, the Thing is not there any more (which makes sense).

If I add it again, I have 4 in the rule engine selection menu.

Which version of OH?

Oh sorry :wink:
2.5 M3