[SOLVED] New Z-Wave Device: What steps after adding to the database?

I’ve add a new-ish GE/Jasco switch to my Z-wave network. First time for me to work with a new device. Successfully added the device to Mr. Jackson’s database (thank you!). GE ZW4008DV

The database guide says “For openHAB, the XML files are automatically produced and made available for a Pull Request into the binding repository in Github.” This leads me to believe that I should sit back and wait for the next commit. Are there steps I should take? I’m not experienced with anything beyond Github downloads. If there are steps I should take, pointers to appropriate “how-tos” are appreciated. Thank you.

Yep - that’s correct. I normally do updates once or twice a week (I will do one tonight or tomorrow).

You will need to update the binding once the database is updated on github. See the following link -:

Thank you. Just installed the latest binding, but still an unknown device. Looks like I entered the wrong value for the firmware version so the new binding still can’t find it. Will try again on next database commit.

Watching the zwave debug logs pointed me to the firmware version mismatch in the database as the problem. When I corrected that back in the device database and waited for the next build, following all the other guides for reinstalling the binding, it connected correctly. I’m grateful for the the community’s effort to create the resources showing me how to make a small contribution.

I also installed a Jasco ZW4008 switch that came in as an “unknown” device. I performed an apt-get update and upgrade that had openhab/add-ons in the list. I run a Raspberry Pi.

I shutdown and restarted the OH service, still no joy.

Do I need to delete the Thing from the Inbox and re-discover it?

Firstly I would suggest to ensure that you’re running the latest snapshot of the binding. If that still doesn’t help, then please provide the properties for your device (as shown in paperUI).

Are these the images that you were asking about? The Show Properties field is empty.

Strange. To see the properties you need to click on “Show Porperties”.
But anyway, your device is in the database:
Now we need to find out your zwave binding version:
go to Karaf and type bundle:list|grep -i zwave*
Post the output, should be something like:
270 x Active x 80 x 2.5.1 x openHAB Add-ons :: Bundles :: ZWave Binding

Thanks for your help on this.

You are running a very old release of openHAB (2.4). In terms of zwave you are using a binding a century old :grinning:
You need to upgrade your installation, please follow:

First I did the upgrade from 2.4 to 2.5.1-2 without any issues.
However, on reboot, my ZWave stick started to cycle on a “handler_missing” error.

I determined that it was because my failed device was still in the OH database so I deleted it in PaperUI. Still a problem with the Controller cycling and the failed device kept showing up in my Inbox.

I went and got the Z-Wave PC Controller 5 software utility. plugged the ZWave stick into my PC, marked the node as “failed”, then “delete failed”.

Re-inserted the ZWave stick into my Raspberry, went back into PaperUI and deleted the device from the Inbox again. This time the Inbox was NOT refreshed by the Stick memory.

Back in business.

Thanks for all of your help.

1 Like