[SOLVED] Newbie SNMP Binding issue/question

Hi All,

I have only been playing with openHAB for a few hours and really like what i’ve seen so far. This is possibly a silly question but i’m having some problems with the SNMP binding. Its added and i’ve set the listening port to 161 in the config file. I am trying to query a value from a QNAP NAS with SNMP enabled on port 161. I can use a MIB browser and see a value however the item that i’ve setup doesn’t seem to return a value.

Item config:

String DiningRoom_NAS_SystemName "System Name"  { snmp="<[]" }


Text item=DiningRoom_NAS_SystemName

When I look at the value from the Basic it just shows the item label.

I have tried the OID with and without a fullstop at the beginning and neither seem to work. I have also tried changing it to a false IP address to see if it would show an obvious error but that didn’t work either.

Anyone have any ideas?

If i’ve missed any key info, please let me know.

Many thanks and happy new year



String DiningRoom_NAS_SystemName "System Name [%s]"  { snmp="<[]" }

Thanks for replying. I’ll give that a try when I get home from work. Out of interest, what does the [%s] add?

Very pleased to say that worked!! Thank you very much.

Glad to see it working for you.:grinning:

If you would please mark the topic solved by clicking the square box on the post (bottom right corner) that provided the solution. Also edit the title to start with [Solved] as this will help others with a similar issue find a quick solution.