[SOLVED] No Connection to openhabian after clearing cache

  • Platform information:
    • Hardware: _RaspberryPi3b
    • OS: _Openhabian
    • openHAB version:2

Hey there,
i´m running into big trouble clearing the caches. What i did is trying to clear the cache like this. After that my system won´t start anymore.

  • openhab-cli stop
  • openhab-cli clean-cache
  • openhab-cli start

From that point i wasn´t able to start the service openhabian again.
When i do:
sudo openhab-cli start i will get this:
The System want´s to start but the start fails
i´m also unable to reach to the console. trying this, i get this error:

i´m a noob in linux systems and i´m breaking my head with this. it would by very greatful if someone can put me on the right way.

Please do not use openhab-cli start but

sudo systemctl start openhab2.service

as openHAB should be started as a service when using GNU/Linux.

Thanks Udo,

i tried this…getting this20

nothing happens after that - the log stay emtpy

What do you get when typing

systemctl status openhab2.service


1 Like

Myabe retry to use

openhab-cli clean-cache
1 Like

ok thanks - i will try and give feedback - many thanks!!!

@bernd1109 if the above doesn’t work try:

sudo systemctl stop openhab2.service

sudo openhab-cli clean-cache

sudo reboot

Sometimes a reboot, opposed to just a restart, will fix the issue.

Best of Luck

FYI, when you are using systemd to control your services you can leave out the trailing .service:

sudo systemctl [stop|start|restart|status] openhab2

I’m using RPI same as the OP and have always used the trailing .service for stopping and starting. I just checked if using the command without .service would stop/start OH and it does.

So now I have to ask, other than being 8 key strokes shorter, what’s the difference between the two?


There’s no other difference that I know. Just a shortcut built in systemd service handling.

1 Like

@gitMiguel My slow typing fingers would like to say thank you.:joy: Anytime I learn something new is good but even better when the result is less typing.:grinning:


1 Like

Thanks to all for this quit support - it seems to work again.
Have a great weekend!

@bernd1109 Glad you got it working.:+1:

Please mark the post solved by clicking the square box (bottom right corner) on the post that provided the solution. Also edit the title, add [Solved] to the beginning, this will help others with similar issues find a quick solution.


1 Like

Ran into this issue as well, this did the trick!
Thank you

1 Like

OH MY GOD - after several other posts, trying several other methods, this one did the trick.

i was afraid i had to start all over again.