[SOLVED] No openhab2-bindings after fresh installation


I am running OH2 since quite some time on my RPi - due to constant fear the SD card will die, I am about to move it to a VM.
So I did a fresh raspbian strecht installation, update to latest, Java installed, mySQL.
Then backed up the old via backup script, SCPed it over to the new host and restored it, started it up and worked. Mostly.
I am getting every few minutes an error in the log that bindings cannot be installed. Checking PaperUI, I saw that there are only the 1.x legacy bindings and actions available and not one single 2.x binding.
So clearly it cannot install it automatically, I cannot manually.
Any ideas what went wrong here?

Let’s start with the basics.
What version did you move from?
What version did you install?
What method did you use to install the new version?
How did you expectt any assistance without basic information?.

Bruce, sorry I actually thought that this is not really important but here we go:

It was a new installation from scratch, directly to 2.4 via apt-get
no errors during the process.
then copied over the backup and restored (via this https://www.openhab.org/docs/installation/linux.html#backup-and-restore)
This was also a 2.4 version.
I am not at home, but the error is something like this:
[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-xxx

As said, it looks like it is unable to access the bindings/features of openhab2. Can add more later

What version did you move from?
How did you back it up?
What method did you use to install 2.4 from scratch?

sorry I don’t understand your comments. This has been answered above or what are you looking for?
Version 2.4 - on source and target.
backup and restore via official documentation - link above

installation of openHab 2 was done via comand, via apt-install. not sure what else I can add to this

I would ask if you can go to paper ui and manually install one binding. If so then that eliminates a potential permissions or other setup issue in the new machine.

If it does not let us know.

If installing in paper ui manually does work then I would shutdown the new system, clean the cache and restart. Give it several minutes and see what happens.

Last question how do you have binding installed in general using config files or paper ui?

Hi Danny,

thanks for getting back.
In my old (and running environment) I have them installed via PaperUI.

On the new box, I do not even have them to chose from. No bindings are there, only OH1 legacy bindings to chose from. That is why I cannot do anything manual.


in order to troubleshoot, I purged openhab2 from my installation, did a reboot and installed it again.
It is ok now, thanks for your input

1 Like