[SOLVED] No sitemaps found, no errors in log

Hardware: Intel 64bit processor, 32gb ram
OS: Windows 10
Java Runtime Environment: Zulu-10
openHAB version: OpenHAB 2.5.0

I’m just going through the tutorials to learn how to use OpenHab. I have followed up to creating the sitemaps however, when I go to basicUI, I get a message saying I haven’t created any sitemaps.
After researching and finding others who have had the same problem, I have double checked my syntax, spelling and case sensitivity. I have tried creating a very basic sitemap by copying an example test sitemap. Nothing I do fixes the problem. The logs don’t even mention looking for a sitemap as far as I can tell.

Heres the basic sitemap based on the tutorial:

sitemap default label=“Bedroom lights”
{
Switch item=Presence_Mobile_Tim label=“Tims Phone”
}

and my items file:

Switch Presence_Mobile_Tim “Tims Phone” { channel=“network:pingdevice:5877b4d6:online” }

Number Control_Switch_Bedroom “Bedroom light switch” { channel=“hue:0820:0017882d75fd:6:dimmer_switch” }

Edit: None of my rules are working either? Is OpenHAB simply not parsing files?

Nevermind. It turns out, when I was saving the files, .txt was being appended. After deleting the .txt, the sitemaps appeared.

1 Like