[SOLVED] OH2 and ebus


I am mucking about with OH2 and I’m really loving what I see. Good work!
I was wondering if there are any recommendations about configuring the ebus binding in OH2?
OH 2.0.0.b4
ebus binding 1.9.0.b4

My current configs (which I ported from my OH1 setup):



Number  cv_controller_temp_room_status         "Room temperature status [%.1f]"    { ebus="id:controller.temp_room.status, refresh:10" }
Number  cv_controller_status_global            "System Status [%.1f]"              { ebus="id:controller.status_global_system_off, refresh:10" }


sitemap cv label="Central heating" {
    Frame label="Boiler" {
        Text item=cv_controller_temp_room_status
        Text item=cv_controller_status_global

I do seem to get the information, so all seems ok, but I was wondering if there is a better approach, or an OH2 approach?
Is there even a way to configure a thing for this binding?

Only 2.0 version bindings generate Things and Channels. 1.9 version bindings are configured and use the same as we always have with OH 1.x. So what you have looks good. At least until there is an ebus 2.0 binding.

I’m despairing. A lot of days I trying to setup a working OH2 configuration for the ebus add-in. What files are necessary ?

The add-on is working. I configured /etc/openhab2/services/ebus.cfg


sudo tailf /var/log/openhab2/events.log
2017-04-18 19:47:19.202 [ExtensionEvent ] - Extension ‘binding-ebus1’ has been installed.

tailf /var/lib/openhab2/persistence/ebus/ebus-all.csv
2017-04-22 22:03:44;“02”;“10”;“08”;B5 11;“01”;01;“89”;“00”;“09”;4B 48 00 80 44 5E 00 00 FF;“B8”;[OK] Vaillant: Brenner zu Regler
2017-04-22 22:03:45;“02”;“10”;“08”;B5 11;“01”;02;“8A”;“00”;“06”;03 3C 96 46 82 7A;“82”;[Analyse] Vaillant: Brenner zu Regler
2017-04-22 22:03:46;“02”;“10”;“08”;B5 11;“01”;00;“88”;“00”;“08”;5A 02 13 00 1F 00 00 00;“7B”;
2017-04-22 22:03:47;“02”;“10”;“08”;B5 03;“02”;00 01;“2F”;“00”;“0A”;FF FF FF FF FF FF FF FF FF FF;“0F”;
2017-04-22 22:03:50;“02”;“10”;“08”;B5 10;“09”;00 00 00 00 FF FF 05 FF 00;“84”;“00”;“01”;01;“9A”;[OK] Vaillant: Regler zu Brenner
2017-04-22 22:03:52;“02”;“10”;“08”;B5 12;“02”;00 00;“CA”;“00”;“00”;;“00”;[Analyse] Vaillant: Pumpenstatus 2???
2017-04-22 22:03:54;“02”;“10”;“08”;B5 11;“01”;01;“89”;“00”;“09”;4B 48 00 80 44 5E 00 00 FF;“B8”;[OK] Vaillant: Brenner zu Regler
2017-04-22 22:03:55;“02”;“10”;“08”;B5 11;“01”;02;“8A”;“00”;“06”;03 3C 96 46 82 7A;“82”;[Analyse] Vaillant: Brenner zu Regler

But now ? What ist to do to see anything in OH WebUI ? I did

sudo vi /etc/openhab2/sitemaps/ebus.sitemap

sitemap ebus label=“Central heating” {
Frame label=“Boiler” {
Text item=HU_Temp_Warm_Wather
Text item=HU_Temp_Warm_Wather1
Text item=HU_Temp_Warm_Wather2
Text item=HU_Temp_Warm_Wather3


sudo vi /etc/openhab2/items/ebus.item

/** Heating **/
Group HeatingUnit “Heating” (All)
Group Solar “Solar” (All)

Group SOL_Chart1 (HeatingUnit)
Group SOL_Chart2 (HeatingUnit)
Group HU_Chart1 (HeatingUnit)
Group HU_Chart2 (HeatingUnit)

Number HU_Temp_Warm_Wather “Hotwater temp.[%.1f °C]” { ebus= { channelid: “burner_v.temp_boiler” } }
Number HU_Temp_Warm_Wather1 “Hotwater temp.[%.1f °C]” { ebus1= { channelid: “burner_v.temp_boiler” } }
Number HU_Temp_Warm_Wather2 “Hotwater temp.[%.1f °C]” { ebus= { id: “burner_v.temp_boiler, refresh:10” } }
Number HU_Temp_Warm_Wather3 “Hotwater temp.[%.1f °C]” { ebus1= { id: “burner_v.temp_boiler, refresh:10” } }

for testing purposes I tried different syntax.

But nothing is happen. Is there any step by step documentation for using ebus 1.9 with OH2 ? Or there are any hints for me ?

Thanks to all.


i use a Wolf COB-20 with SM1 solar mobule.
Is the COB-20 compatible with the eBus binding version or is the configuration files missing for this components?
thanks in advance.

I believe you need to specify the destination. The following config should work for bai00 and vrc470.

/* eBus Thermostat */
Number	Temperature_Outside					"Temperatuur buiten [%.1f °C]"			<temperature>	(gHeating,gWeather,Chart_Temperature_Outdoor,Persist_Change)	{ ebus="id:controller.temp_outside.temp_outside, dst:15, refresh:300" }
Number	Temperature_GF_Living				"Temperatuur [%.1f °C]"					<temperature>	(gHeating,GF_Living,Chart_Temperature_Room,Persist_Change)		{ ebus="id:controller.temp_room.temp_room, dst:15, refresh:300" }
Number	Temperature_Target_GF_Living 		"Setpunt ruimte [%.1f °C]" 				<temperature>	(gHeating,GF_Living,Chart_Temperature_Room,Persist_Change,Persist_5Minutes) 		{ ebus="id:controller.temp_d_room_disp, dst:15, refresh:60" }
/*Number	Temperature_Setpoint_GF_Living 		"Setpunt ruimte [%.1f °C]" 				<temperature>	(gHeating,GF_Living,Chart_Temperature_Room,Persist_Change) 			{ ebus="id:controller.temp_d_room_override, dst:15, refresh:60" } */
Number	Heating_Program						"Bedrijfsmodus"							<settings>		(gHeating)														{ ebus="id:heating.program_heating_circuit, set:heating.set_program_heating_circuit.program, dst:15, refresh:60" }
Number	Heating_SpecialProgram				"Speciale modus"						<settings>		(gHeating)														{ ebus="id:heating.program_heating_circuit_special,  set:heating.set_program_heating_circuit_special.program,dst:15, refresh:60"}
Number	Heating_Temperature_Setpoint_Day	"Dag [%.1f °C]"							<temperature>	(gHeating)														{ ebus="id:heating.temp_d_day, dst:15, refresh:300, set:heating.set_temp_d_day.temp_d_day" }
Number	Heating_Temperature_Setpoint_Night	"Nacht [%.1f °C]"						<temperature>	(gHeating)														{ ebus="id:heating.temp_d_night, dst:15, refresh:300, set:heating.set_temp_d_night.temp_d_night" }
Number	DHW_Program							"Bedrijfsmodus warm water"				<settings>		(gHeating)														{ ebus="id:dhw.program_dhw_circuit, dst:15, refresh:60, set:dhw.set_program_dhw_circuit.program" }
Number	DHW_Temperature_Setpoint			"Warm water [%.1f °C]"					<temperature>	(gHeating)														{ ebus="id:dhw.temp_d_dhw, dst:15, refresh:300, set:dhw.set_temp_d_dhw.temp_d_dhw" }
Number	DHW_Temperature_Target				"Setpunt buffer boven [%.1f °C]"		<temperature>	(gHeating)														{ ebus="id:dhw.temp_d_actual_dhw, dst:15, refresh:300" }
Number	Heating_Curve						"Stooklijn [%.1f]"						<line>			(gHeating)														{ ebus="id:heating.temp_hcurve, dst:15, refresh:300, set:heating.set_temp_hcurve.temp_hcurve" }
Number	Heating_GlobalOff					"Systeem uit"							<settings>		(gHeating)														{ ebus="id:controller.status_global_system_off, dst:15, refresh:300" }
String	Heating_Program_Status 														<heating>		(gHeating)

/* eBus Boiler */
Number	DHW_Temperature_Cylinder_Top		"Temperatuur buffer boven [%.1f °C]"	<temperature>	(gHeating,Chart_Temperature_Solar,Persist_Change)				{ ebus="id:dhw.temp_cylinder.temp_cylinder, dst:08, refresh:60" }
Number	Boiler_Temperature_Target_Supply	"Setpunt ketel vertrek [%.1f °C]"		<temperature>	(gHeating,Chart_Temperature_Heating,Persist_Change,Persist_5Minutes)	{ ebus="id:boiler.temp_d_flow, dst:08, refresh:60" }
Number	Boiler_Temperature_Supply			"Temperatuur ketel vertrek [%.1f °C]"	<temperature>	(gHeating,Chart_Temperature_Heating,Persist_Change)				{ ebus="id:boiler.temp_flow.temp_flow, dst:08, refresh:60" }
Number	Boiler_Temperature_Return			"Temperatuur ketel retour [%.1f °C]"	<temperature>	(gHeating,Chart_Temperature_Heating,Persist_Change)				{ ebus="id:boiler.temp_return.temp_return, dst:08, refresh:60" }
Number	Boiler_State_Pump					"Pomp [MAP(1aan0uit.map):%s]"			<pump>			(gHeating)														{ ebus="id:boiler.state_pump, dst:08, refresh:60" }
Number	Boiler_Modulation_Pump				"Pompsnelheid [%d %%]"					<pump>			(gHeating)														{ ebus="id:boiler.modulation_pump, dst:08, refresh:60" }
Number	Boiler_Speed_Target_Fan				"Setpunt ventilatorsnelheid [%d rpm]"	<fan>			(gHeating)														{ ebus="id:boiler.speed_d_fan, dst:08, refresh:300" }
/*Number	Boiler_Speed_Fan					"Ventilatorsnelheid [%d rpm]"			<fan>		(gHeating)														{ ebus="id:boiler.speed_fan, dst:08, refresh:300" } */
Number	Boiler_State_GasValve				"Gasklep [MAP(240gesloten15open.map):%s]"	<settings>	(gHeating)														{ ebus="id:boiler.state_gas_valve, dst:08, refresh:60" }
Number	Boiler_State_DiverterValve			"Driewegklep [MAP(3wegklep.map):%s]"	<settings>		(gHeating)														{ ebus="id:boiler.state_diverter_valve, dst:08, refresh:60" }
Number	Boiler_Pressure						"Waterdruk [%.2f bar]"					<pressure>		(gHeating)														{ ebus="id:boiler.pressure.pressure, dst:08, refresh:300" }
Number	Boiler_Ionization					"Ionisatie [%d]"						<fire>			(gHeating)														{ ebus="id:boiler.value_io, dst:08, refresh:300" }
Number	Heating_Runtime						"Draaiuren CV [%d h]"					<clock>			(gHeating)														{ ebus="id:heating.runtime, dst:08, refresh:300" }
Number	DHW_Runtime							"Draaiuren SWW [%d h]"					<clock>			(gHeating)														{ ebus="id:dhw.runtime, dst:08, refresh:300" }
Number	Heating_Starts						"Starts CV [%d x100]"					<clock>			(gHeating)														{ ebus="id:heating.starts, dst:08, refresh:300" }
Number	DHW_Starts							"Starts SWW [%d x100]"					<clock>			(gHeating)														{ ebus="id:dhw.starts, dst:08, refresh:300" }

Good evening!

I have the problem that the runtime will not find the path of my custom json pharser in OH2. At the moment I working at the migration from OH1.X to OH2…

The path of my json file is: “C:\openhab-2.2.0-SNAPSHOT\conf\services\ebus-config.json”

Is someone able to help to find the correct path declaration for my ebus.cfg file?

Thank you very much!

You should follow this topic, same question.

1 Like

Hi csowada,

it was to late for me yesterday…I saw the qustion but not your answer, sorry for that! :sleeping:

Now this path works for me: “parserUrl=file:///C:/openhab-2.2.0-SNAPSHOT/conf/services/ebus-config.json”

Ach ja, it is a Windows system by the way…

Off Topic: I think there is a way to define a shorter path with this “etc” right? At the end it is unnecessary because it works but I’m really intrested in this…

Thanks a lot csowada

No /etc is a root directory for configurations on linux systems.

I have actually the following isue with the ebus binding.

I´m using the esera ebus to lan coupler and are not able to get any data from it to openhab.

ebus config:
parsers=common, vaillant-vrc430


Do i have to install additionally an ebus server on my openhab system?

No you don’t

It took a while for me to get it running as well…

1 no additional server.

2 use the provided (windows) software to make sure everything is working fine

3 connect to OpenHAB

Read the instructions carefully, as I didn’t understand the led in the ebus coupler needed to flicker real fast before it would work.