[SOLVED]OH2.Habmin directed to Habmin1 problem

Previously, I use Habmin2 0.1.2 with OH2.
However, as I face a zwave binding performance problem.
More information is here,

I want to give a try with Habmin2 0.1.3.

I end up finding the GUI is totally different. 0.1.3 is more close to Habmin GUI, I think. In this case, I assume there may be some information for that somewhere.

Can someone share a link for the Habmin2 0.1.3 zwave operation, like device discovery/exclusion?
Or should I just return back to Habmin2 0.1.2 instead of Habmin2 0.1.3?

Thank you.

HABmin 0.1.3 is almost exactly the same as 0.1.2 - it’s just got a few small updates and is certainly not ‘totally different’. This is the changelog -:


  • Update folder used for saving rules (e093065)


  • Add confirmation dialogs when deleting items (b9aa20d)
  • Add unlink button in channels list (56cb276)


  • Updated German translations (be34d1a)
  • Provide user selection for default persistence (8290cbd)

I’m pretty sure I’ve already sent you this link in a different thread, but here it is again.

It’s also worth noting that HABmin is not linked to ZWave in any way, so the performance issues won’t change by changing HABmin versions.

Chris, thank you for all your information for 0.1.3.
And thank you for sending me the link again.

But things goes very strange on my system.

On last Friday, my Habmin2’s GUI is the same as the picture this link.

But today, every time I click Habmin in localhost:8080.
It flashes
"Loading HABmin web administration console
HABmin Version:0.1.3-snapshot
Language: English"
very shortly, then go to another page which is with four tabs,
persistence configuration automation system.

The web GUI change totally. It is not like the one in
any more.

As I have no idea how to use the new GUI, I tried to return back the old one. However, even though I put habmin2 0.1.2 under addon. It still flash It flashes
"Loading HABmin web administration console
HABmin Version:0.1.3-snapshot
Language: English".
Isn’t that very strange?

That’s why I said 0.1.3 change very big. Maybe I make some mistake in my statement. But do you have some idea for this Habmin2 GUI change problem above?

And also last Friday I install OH1 and Habmin1. And the Habmin1 GUI look just the same as now my Habmin2 GUI 0.1.3. I am sure whether OH1 and Habmin1 installation does matter for the problem above or not.

Thank you.

There has not been any change in the GUI, so I would suspect another issue with your system, not a change in HABmin.

Chris, thank you for your response.

Above is my current web GUI.
But previously, my web GUI is below.

I have no idea why it change.
Can you shed some light about this problem? Thank you.

It looks like you’ve managed to install HABmin 1.

I did install OH1 and HABmin1 in another directory.

But do you mean that they influence HABmin2?
Am I supposed to remove OH1 and HABmin1 to make HABmin2 return back the GUI it used to be?

Thank you.

I don’t know - I’ve never tried. HABmin1 is not compatible with OH2 and I have no idea what you’ve done so it’s difficult to say what you need to do now.

Chris, I think I may confused you.

I did put the HABmin1 jar file under OH1/addons. But I didn’t put HABmin1 jar file with OH2.

In detail,
I put HABmin1 jar under OH1/addons.
I put HABmin2 jar under OH2/addons.
And now the GUI change problem comes up when I go to OH2 and ./start.sh there.

Do you have any suggestion or comments? Thank you.

I don’t really understand what you’ve done - all I can say is that the GUI that you are seeing is from OH1, so I would suggest reversing whatever you did. I’m not sure I can help you though - sorry.

Thank you for your advice and clarification.
Sorry I am still confusing.

For OH1 GUI, do you mean this one or the other one?

Thank you.

That is from HABmin1 - you should be able to tell this if you look on the download pages ???

Thank you for clarification.

Yes. I know I download Habmin1 and Habmin2.
But this GUI come from my Habmin2 under OH2.
That’s why I am confusing.

Anyway, thank you.

You are right! Did have the same problem as i had installed OH1 and OH2 side by side on the same Raspberry. PaperUI than always calls Habmin1 instead Habmin2. Very confusing.

Hi anfuchs, thank you for your information.

Would you please share with us more about how do you fix it?
I am still stuck on this problem.

Can I fix this problem by simply deleting OH1 and Habmin1 under directory?
But as my OH1 and OH2 is under different directory, I really can NOT understand why it matter.

In OH1, I know web related files is under webapps sub directory.
But even webapps sub directory disappear in OH2, and I really do not have idea where and what I should look for my problem.

Thank you.

Fixed it by complete removing OH1 :stuck_out_tongue_winking_eye:

Sorry, thats all i can say about that.

Thank you for your response.

But what do you mean by complete removing OH1?
I already remove the OH1 directory. But OH2 is still be directed to the HABmin1 GUI.
It looks like something has done somewhere automatically.
But I have no idea what and where are they.

Do you have somewhere else to suggest to remove OH1 completely?
Thank you.

Oh well … forget that. But i’am really sure i did have the exactly same problem. And made the hole Raspberry from scratch. Startet all over with OH2

Thank you for your information.

So do you mean that you do all the things from the beginning?
Meaning reinstall operating system again, and then reinstall OH2 on top of it.

As I use ubuntu, accordingly, I should reinstall ubuntu, and then install OH2?
Is that what you mean?

Thank you.

Because i’am using Raspbian Jessie Lite without any desktop or gui, just console - for me that was the fastest and easies way to do it. Flashing the SD-Card, unzipping OH2 … ready to go.

I don’t know what kind of computer you are using and for what else it is. my raspberry does nothing else then OH2. so the decision was quit easy.

Don’t forget to backup your items, rules, sitemaps and so on!

(I switched quit a while between OH1 and OH2. But now i’ll stay with OH2 … Future is now :stuck_out_tongue_winking_eye:)